summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Kerr <chris.kerr@mykolab.ch>2022-07-24 02:07:26 +0100
committerSam James <sam@gentoo.org>2022-07-24 02:07:26 +0100
commitf93a3234176a3c5d61978210fa60f004cad82086 (patch)
treed2cd9dd1bd2dbdd6ab42515b43e511f4e1ad9433 /virtual
parentdev-libs/pocl: keyword 3.0 for ~ppc64 (diff)
downloadgentoo-f93a3234176a3c5d61978210fa60f004cad82086.tar.gz
gentoo-f93a3234176a3c5d61978210fa60f004cad82086.tar.bz2
gentoo-f93a3234176a3c5d61978210fa60f004cad82086.zip
virtual/opencl: add pocl to postinst
Closes: https://bugs.gentoo.org/860282 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'virtual')
-rw-r--r--virtual/opencl/opencl-3-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/virtual/opencl/opencl-3-r2.ebuild b/virtual/opencl/opencl-3-r2.ebuild
new file mode 100644
index 000000000000..56a9bf8353ab
--- /dev/null
+++ b/virtual/opencl/opencl-3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for OpenCL API"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="|| ( dev-libs/opencl-icd-loader[${MULTILIB_USEDEP}]
+ dev-libs/ocl-icd[khronos-headers,${MULTILIB_USEDEP}] )"
+
+pkg_postinst() {
+ elog
+ elog "In order to take advantage of OpenCL you will need a runtime for your hardware."
+ elog "Currently included in Gentoo are:"
+ elog
+ elog " * open:"
+ elog " - dev-libs/intel-compute-runtime - integrated Intel GPUs from Broadwell onwards. 64-bit only;"
+ elog " - dev-libs/pocl - to run OpenCL programs on your CPU, if you do not have a supported GPU;"
+ elog " - dev-libs/rocm-opencl-runtime - AMD GPUs supported by the amdgpu kernel driver. 64-bit only;"
+ elog " - media-libs/mesa[opencl] - some older AMD GPUs; see [1]. 32-bit support;"
+ elog
+ elog " * proprietary:"
+ elog " - dev-libs/amdgpu-pro-opencl - AMD Polaris GPUs. 32-bit support;"
+ elog " - dev-util/intel-ocl-sdk - Intel CPUs (*not* GPUs). 64-bit only;"
+ elog " - x11-drivers/nvidia-drivers[uvm] - Nvidia GPUs; specific package versions"
+ elog " required for older devices [2]. 32-bit support."
+ elog
+ elog " [1] https://dri.freedesktop.org/wiki/GalliumCompute/"
+ elog " [2] https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/"
+ elog
+}