summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-01-15 09:37:51 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2024-01-15 09:41:10 -0800
commit67d5cfe247f9e13d41db5eb443796eb3ca65d06f (patch)
tree7de4fa306c64aa37ce6f615aea97506f5295e277 /www-apache/mod_auth_openidc/mod_auth_openidc-2.4.14.4-r1.ebuild
parentdev-libs/cjose: new package, dep for www-apache/mod_auth_openidc (diff)
downloadgentoo-67d5cfe247f9e13d41db5eb443796eb3ca65d06f.tar.gz
gentoo-67d5cfe247f9e13d41db5eb443796eb3ca65d06f.tar.bz2
gentoo-67d5cfe247f9e13d41db5eb443796eb3ca65d06f.zip
www-apache/mod_auth_openidc: new package, move from infra overlay
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'www-apache/mod_auth_openidc/mod_auth_openidc-2.4.14.4-r1.ebuild')
-rw-r--r--www-apache/mod_auth_openidc/mod_auth_openidc-2.4.14.4-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/www-apache/mod_auth_openidc/mod_auth_openidc-2.4.14.4-r1.ebuild b/www-apache/mod_auth_openidc/mod_auth_openidc-2.4.14.4-r1.ebuild
new file mode 100644
index 000000000000..4ab411903ee7
--- /dev/null
+++ b/www-apache/mod_auth_openidc/mod_auth_openidc-2.4.14.4-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+#
+
+EAPI=8
+
+inherit depend.apache apache-module autotools
+
+DESCRIPTION="OpenID Connect Relying Party implementation for Apache HTTP Server 2.x"
+HOMEPAGE="https://github.com/OpenIDC/mod_auth_openidc"
+SRC_URI="https://github.com/OpenIDC/mod_auth_openidc/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="~amd64"
+IUSE="redis brotli"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+
+RDEPEND="net-misc/curl
+ brotli? ( app-arch/brotli:= )
+ sys-libs/zlib:=
+ dev-libs/openssl:=
+ dev-libs/apr
+ dev-libs/jansson:=
+ dev-libs/cjose
+ dev-libs/libpcre
+ redis? ( dev-libs/hiredis:= )
+ app-misc/jq"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+APACHE2_MOD_CONF="10_mod_auth_openidc"
+APACHE2_MOD_DEFINE="AUTH_OPENIDC"
+DOCFILES="README.md ChangeLog AUTHORS INSTALL auth_openidc.conf"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_ARGS=(
+ $(use_with brotli)
+ $(use_with redis hiredis)
+ )
+ econf "${ECONF_ARGS[@]}"
+}
+
+src_compile() {
+ # Do not use apache-module_src_compile ; it does not compile properly
+ default
+}
+
+src_install() {
+ # Do not use apache-module_src_install ; it does not link properly
+ default
+
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}/${APACHE2_MOD_CONF}.conf"
+ dodoc ${DOCFILES}
+}
+
+pkg_postinst() {
+ apache-module_pkg_postinst
+}