summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_auth_radius
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_auth_radius')
-rw-r--r--www-apache/mod_auth_radius/Manifest1
-rw-r--r--www-apache/mod_auth_radius/files/1.5.8-includes.patch25
-rw-r--r--www-apache/mod_auth_radius/files/1.5.8-remote_ip-obsolete.patch21
-rw-r--r--www-apache/mod_auth_radius/metadata.xml8
-rw-r--r--www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild40
5 files changed, 95 insertions, 0 deletions
diff --git a/www-apache/mod_auth_radius/Manifest b/www-apache/mod_auth_radius/Manifest
new file mode 100644
index 000000000000..8b66fcde8259
--- /dev/null
+++ b/www-apache/mod_auth_radius/Manifest
@@ -0,0 +1 @@
+DIST mod_auth_radius-1.5.8.tar 122880 SHA256 6a16cb64c8e3da5ccef5db007d3ab3fa53274bdb37c5f6b1821a12de42aa6d93 SHA512 0fcc43a44ea17b33595a850abb03ff6b92e100dfbeffc82caa9516f6eb7914fb463cb62286d624203a2c7035d05a107dda7b68c5cedf7de3b8be95b9266b6988 WHIRLPOOL 15ffe4db98758e0ef41390f46e97f686ed678b9358347de3b3257ba8d0fac9623935563040a0138c8c81179deb8dca0f998f90441c8b538d45e14548fbc97403
diff --git a/www-apache/mod_auth_radius/files/1.5.8-includes.patch b/www-apache/mod_auth_radius/files/1.5.8-includes.patch
new file mode 100644
index 000000000000..b1482c5f9bee
--- /dev/null
+++ b/www-apache/mod_auth_radius/files/1.5.8-includes.patch
@@ -0,0 +1,25 @@
+diff -uNr mod_auth_radius-1.5.8.ORIG/mod_auth_radius-2.0.c mod_auth_radius-1.5.8/mod_auth_radius-2.0.c
+--- mod_auth_radius-1.5.8.ORIG/mod_auth_radius-2.0.c 2013-05-08 14:26:19.103330264 +0100
++++ mod_auth_radius-1.5.8/mod_auth_radius-2.0.c 2013-05-08 14:29:40.331333283 +0100
+@@ -287,15 +287,21 @@
+
+ */
+
++#include <arpa/inet.h>
+ #include <netdb.h>
+ #include <openssl/md5.h>
+ #include <sys/stat.h>
++#include <sys/types.h>
++#include <unistd.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+
+ #include "httpd.h"
+ #include "http_config.h"
+ #include "http_core.h"
+ #include "http_log.h"
+ #include "http_protocol.h"
++#include "http_request.h"
+ #include "util_md5.h"
+ #include "apr_general.h"
+ #include "apr_tables.h"
diff --git a/www-apache/mod_auth_radius/files/1.5.8-remote_ip-obsolete.patch b/www-apache/mod_auth_radius/files/1.5.8-remote_ip-obsolete.patch
new file mode 100644
index 000000000000..77d0880e8d97
--- /dev/null
+++ b/www-apache/mod_auth_radius/files/1.5.8-remote_ip-obsolete.patch
@@ -0,0 +1,21 @@
+diff -uNr mod_auth_radius-1.5.8.ORIG/mod_auth_radius-2.0.c mod_auth_radius-1.5.8/mod_auth_radius-2.0.c
+--- mod_auth_radius-1.5.8.ORIG/mod_auth_radius-2.0.c 2013-05-08 14:18:02.746322816 +0100
++++ mod_auth_radius-1.5.8/mod_auth_radius-2.0.c 2013-05-08 14:19:03.589323729 +0100
+@@ -683,7 +683,7 @@
+ * benefit here.
+ */
+ apr_snprintf(one, COOKIE_SIZE, "%s%s%s%s%s%08x", scr->secret,
+- r->user, passwd, c->remote_ip, hostname, expires);
++ r->user, passwd, c->client_ip, hostname, expires);
+
+ /* if you're REALLY worried about what's going on */
+
+@@ -691,7 +691,7 @@
+ ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," secret = %s\n", scr->secret);
+ ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," user = %s\n", r->user);
+ ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," passwd = %s\n", passwd);
+- ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," remote ip = %s\n", c->remote_ip);
++ ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," remote ip = %s\n", c->client_ip);
+ ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," hostname = %s\n", hostname);
+ ap_log_error(APLOG_MARK, APLOG_NOERRNO | APLOG_DEBUG, 0, r->server," expiry = %08x\n", expires);
+ #endif
diff --git a/www-apache/mod_auth_radius/metadata.xml b/www-apache/mod_auth_radius/metadata.xml
new file mode 100644
index 000000000000..3ed4669f55a4
--- /dev/null
+++ b/www-apache/mod_auth_radius/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild b/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild
new file mode 100644
index 000000000000..d9227ff7fe97
--- /dev/null
+++ b/www-apache/mod_auth_radius/mod_auth_radius-1.5.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit apache-module eutils
+
+DESCRIPTION="Radius authentication for Apache"
+HOMEPAGE="http://freeradius.org/mod_auth_radius/"
+SRC_URI="ftp://ftp.freeradius.org/pub/radius/${P}.tar"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+APACHE2_MOD_FILE=".libs/mod_auth_radius-2.0.so"
+APACHE2_MOD_DEFINE="AUTH_RADIUS"
+
+APXS2_ARGS="-c ${PN}-2.0.c"
+
+DOCFILES="README"
+
+need_apache2
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-includes.patch"
+ if has_version ">=www-servers/apache-2.4"; then
+ epatch "${FILESDIR}/${PV}-remote_ip-obsolete.patch"
+ fi
+}
+
+src_compile() {
+ apache-module_src_compile
+}
+
+src_install() {
+ apache-module_src_install
+}