summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_dnssd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_dnssd/files')
-rw-r--r--www-apache/mod_dnssd/files/80_mod_dnssd.conf6
-rw-r--r--www-apache/mod_dnssd/files/mod_dnssd-0.6-httpd24.patch24
-rw-r--r--www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch22
3 files changed, 52 insertions, 0 deletions
diff --git a/www-apache/mod_dnssd/files/80_mod_dnssd.conf b/www-apache/mod_dnssd/files/80_mod_dnssd.conf
new file mode 100644
index 000000000000..1c67f7e86efc
--- /dev/null
+++ b/www-apache/mod_dnssd/files/80_mod_dnssd.conf
@@ -0,0 +1,6 @@
+<IfDefine DNSSD>
+LoadModule dnssd_module modules/mod_dnssd.so
+DNSSDEnable on
+</IfDefine>
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_dnssd/files/mod_dnssd-0.6-httpd24.patch b/www-apache/mod_dnssd/files/mod_dnssd-0.6-httpd24.patch
new file mode 100644
index 000000000000..6eb505810405
--- /dev/null
+++ b/www-apache/mod_dnssd/files/mod_dnssd-0.6-httpd24.patch
@@ -0,0 +1,24 @@
+--- mod_dnssd-0.6/src/mod_dnssd.c.httpd24
++++ mod_dnssd-0.6/src/mod_dnssd.c
+@@ -26,6 +26,9 @@
+ #include <unixd.h>
+ #include <apr_signal.h>
+ #include <mpm_common.h>
++#if AP_MODULE_MAGIC_AT_LEAST(20090130,0)
++#include <mod_unixd.h>
++#endif
+
+ #include <unistd.h>
+
+@@ -576,7 +579,11 @@ static void child_process(apr_pool_t *p,
+
+ ap_assert(d);
+
++#if AP_MODULE_MAGIC_AT_LEAST(20090130,0)
++ ap_unixd_setup_child();
++#else
+ unixd_setup_child();
++#endif
+
+ if (pipe(sigterm_pipe_fds) < 0) {
+ ap_log_error(APLOG_MARK, APLOG_ERR, 0, r.main_server, "pipe() failed: %s", strerror(errno));
diff --git a/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch b/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch
new file mode 100644
index 000000000000..699f2301f442
--- /dev/null
+++ b/www-apache/mod_dnssd/files/mod_dnssd-0.6-ldflags.patch
@@ -0,0 +1,22 @@
+---
+ Respect LDFLAGS and properly use LIBS to avoid missing symbols at runtime.
+
+--- src/Makefile.in
++++ src/Makefile.in
+@@ -16,13 +16,14 @@
+
+ APXS=@APXS@
+ APACHECTL=@APACHECTL@
+-LIBS=-Wl,"@LIBS@" @AVAHI_LIBS@
++LIBS="@LIBS@" @AVAHI_LIBS@
+ CFLAGS=-Wc,"@CFLAGS@" @AVAHI_CFLAGS@
++APXS_LDFLAGS=`for ldflag in $(LDFLAGS); do echo -Wl,$$ldflag; done`
+
+ all: mod_dnssd.la
+
+ mod_dnssd.la: @srcdir@/mod_dnssd.c
+- $(APXS) -c $(CFLAGS) $(LIBS) @srcdir@/mod_dnssd.c
++ $(APXS) -c $(CFLAGS) $(APXS_LDFLAGS) @srcdir@/mod_dnssd.c $(LIBS)
+
+ install: all
+ $(APXS) -i -a mod_dnssd.la