summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-11-17 09:11:10 -0500
committerCraig Andrews <candrews@gentoo.org>2021-11-17 09:12:59 -0500
commit07dbd107323884fb08f4b832acc884a621662665 (patch)
tree9f97d9aaa305488fa0faa48630cdfaca04177d7e /www-apache/mod_h2/mod_h2-2.0.0.ebuild
parentdev-python/pyopencl: add 2021.2.9 (diff)
downloadgentoo-07dbd107323884fb08f4b832acc884a621662665.tar.gz
gentoo-07dbd107323884fb08f4b832acc884a621662665.tar.bz2
gentoo-07dbd107323884fb08f4b832acc884a621662665.zip
www-apache/mod_h2: 2.0.0 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_h2/mod_h2-2.0.0.ebuild')
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/www-apache/mod_h2/mod_h2-2.0.0.ebuild b/www-apache/mod_h2/mod_h2-2.0.0.ebuild
new file mode 100644
index 000000000000..352e2e78dea4
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-2.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}