summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-02-22 09:57:01 -0500
committerCraig Andrews <candrews@gentoo.org>2021-02-22 09:57:23 -0500
commit6aee88d5b00a99598b84483e64e50dce88d1e8ad (patch)
treeecb812fb6192904e749cf3aa4d9c22d752e3ef86 /www-apache/mod_h2
parentwww-servers/lighttpd: Update mime types, #399401 (diff)
downloadgentoo-6aee88d5b00a99598b84483e64e50dce88d1e8ad.tar.gz
gentoo-6aee88d5b00a99598b84483e64e50dce88d1e8ad.tar.bz2
gentoo-6aee88d5b00a99598b84483e64e50dce88d1e8ad.zip
www-apache/mod_h2: 1.15.17 version bump
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache/mod_h2')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.15.17.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 0557ad05b727..e2990fb5cfae 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1 +1,2 @@
DIST mod_h2-1.15.16.tar.gz 702081 BLAKE2B 1f1ce9911c4dba5001d548b99fe08c5a13882a1f44b067a19c3edc178566895522e30d5b949c89754c322eb80a09fd5c07cba740783377b46e2d075e207ca04b SHA512 48e734bafc68acda75a2b9b72b503396bb8c4e58842e5b1ff395389835681a26485cd3795ca3c7fe7be5ad9614b89f305993d2753f1486856eff7599d2892c49
+DIST mod_h2-1.15.17.tar.gz 708333 BLAKE2B 7f7f4625d20dd85e88768cbc1b6347498d2d913b4e778fcac6e01ef2e6676ff4c180385610e5db990d7e9d3ceceafac7e1a08b421c7d99814f9c212b17ac8d76 SHA512 7d6af4123091171273093b4333699bda2469b3e2bd7412e226394f0dc79a5a7d684035538549e13d119c5134016c8b7a3e7aaf8559eec56ed15d849655f11521
diff --git a/www-apache/mod_h2/mod_h2-1.15.17.ebuild b/www-apache/mod_h2/mod_h2-1.15.17.ebuild
new file mode 100644
index 000000000000..e59d601d9ddf
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.15.17.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}