summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mod_mono/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mod_mono/files')
-rw-r--r--www-apache/mod_mono/files/2.2/70_mod_mono.conf88
-rw-r--r--www-apache/mod_mono/files/mod_mono-2.10-apache-2.4.patch146
2 files changed, 234 insertions, 0 deletions
diff --git a/www-apache/mod_mono/files/2.2/70_mod_mono.conf b/www-apache/mod_mono/files/2.2/70_mod_mono.conf
new file mode 100644
index 000000000000..f944039923e9
--- /dev/null
+++ b/www-apache/mod_mono/files/2.2/70_mod_mono.conf
@@ -0,0 +1,88 @@
+# For more information on the Mono* directives, see the man page for
+# mod_mono(8)
+
+<IfDefine MONO>
+ # Set this to False if you manage your ASP.Net server manually through
+ # /etc/init.d/mod-mono-server
+ MonoRunXSP True
+
+ # Set this to Enabled if you want to enable AutoHosting.
+ # See http://www.mono-project.com/AutoConfiguration for more info.
+ # Note that if you want your automatically hosted applications
+ # handled by ASP.NET 2.0 engine you have to enable the aspnet2 USE flag.
+ MonoAutoApplication Enabled
+
+ <IfModule !mod_mono.c>
+ LoadModule mono_module /usr/@LIBDIR@/apache2/modules/mod_mono.so
+ </IfModule>
+
+ <IfModule mod_mime.c>
+ AddType application/x-asp-net .aspx
+ AddType application/x-asp-net .asmx
+ AddType application/x-asp-net .ashx
+ AddType application/x-asp-net .asax
+ AddType application/x-asp-net .ascx
+ AddType application/x-asp-net .soap
+ AddType application/x-asp-net .rem
+ AddType application/x-asp-net .axd
+ AddType application/x-asp-net .cs
+ AddType application/x-asp-net .vb
+ AddType application/x-asp-net .master
+ AddType application/x-asp-net .sitemap
+ AddType application/x-asp-net .resources
+ AddType application/x-asp-net .skin
+ AddType application/x-asp-net .browser
+ AddType application/x-asp-net .webinfo
+ AddType application/x-asp-net .resx
+ AddType application/x-asp-net .licx
+ AddType application/x-asp-net .csproj
+ AddType application/x-asp-net .vbproj
+ AddType application/x-asp-net .config
+ AddType application/x-asp-net .Config
+ AddType application/x-asp-net .dll
+ DirectoryIndex index.aspx
+ DirectoryIndex Default.aspx
+ DirectoryIndex default.aspx
+ </IfModule>
+
+### Please also add "-D MONO_DEMO" in order to activate out-of-the-box mono demo
+###
+
+ # Note that the test application runs on a separate mod-mono-server
+ # instance named "testinst". Athought this is not mandatory, it shows how to
+ # distribute workload between multiple mod-mono-servers. For more info see:
+ # http://www.mono-project.com/Mod_mono
+
+ <IfDefine MONO_DEMO>
+ <IfModule mod_alias.c>
+ Alias /mono "/usr/lib/xsp/test"
+ </IfModule>
+
+ # You might want to specify the version of mod-mono-server
+ # instance that will handle your application. The default
+ # value depends on whether the aspnet2 USE flag was set
+ # during compilation
+ #MonoServerPath testinst /usr/lib/mono/1.0/mod-mono-server.exe
+ #MonoServerPath testinst /usr/lib/mono/2.0/mod-mono-server2.exe
+
+ AddMonoApplications testinst "/mono:/usr/lib/xsp/test"
+
+ <Directory /usr/lib/xsp/test>
+ SetHandler mono
+ MonoSetServerAlias testinst
+
+ <IfModule mod_authz_host.c>
+ Order allow,deny
+ Allow from all
+ </IfModule>
+ <IfModule mod_dir.c>
+ # Sample ASP.NET 1.1/2.0 applications can be accessed
+ # via index2.aspx.
+ DirectoryIndex index.aspx
+ #DirectoryIndex index2.aspx
+ </IfModule>
+ </Directory>
+ </IfDefine>
+### MONO_DEMO end.
+
+</IfDefine>
diff --git a/www-apache/mod_mono/files/mod_mono-2.10-apache-2.4.patch b/www-apache/mod_mono/files/mod_mono-2.10-apache-2.4.patch
new file mode 100644
index 000000000000..86694bfabcc0
--- /dev/null
+++ b/www-apache/mod_mono/files/mod_mono-2.10-apache-2.4.patch
@@ -0,0 +1,146 @@
+Sólo en mod_mono-2.10.new/: attachment.cgi?id=402888
+diff -ur mod_mono-2.10/configure.in mod_mono-2.10.new/configure.in
+--- mod_mono-2.10/configure.in 2011-01-13 23:32:35.000000000 +0100
++++ mod_mono-2.10.new/configure.in 2015-06-07 21:09:26.417127319 +0200
+@@ -336,6 +336,16 @@
+ ], [
+ ])
+
++AC_TRY_RUN([
++ #include <ap_release.h>
++ int main ()
++ {
++ return (AP_SERVER_MAJORVERSION_NUMBER == 2 && AP_SERVER_MINORVERSION_NUMBER == 4) ? 0 : 1;
++ }
++], [
++ APACHE_VER=2.4
++], [
++])
+ fi
+
+ if test ! "$APACHE_VER" = "1.3" -a ! "$APACHE_VER" = "retry" ; then
+@@ -385,6 +395,10 @@
+ AC_DEFINE([APACHE22],,[Compiling for Apache >= 2.2 ])
+ fi
+
++if test "$APACHE_VER" = "2.4" ; then
++ AC_DEFINE([APACHE24],,[Compiling for Apache >= 2.4 ])
++fi
++
+ # check for --with-mono-default-config-dir
+ DFLT_MONO_CONFIG_DIR=`$APXS -q SYSCONFDIR`/mod-mono-applications
+ AC_ARG_WITH(mono-default-config-dir,
+diff -ur mod_mono-2.10/src/mod_mono.c mod_mono-2.10.new/src/mod_mono.c
+--- mod_mono-2.10/src/mod_mono.c 2011-01-13 23:32:35.000000000 +0100
++++ mod_mono-2.10.new/src/mod_mono.c 2015-06-07 21:09:26.421127351 +0200
+@@ -386,7 +386,11 @@
+ apache_get_userid ()
+ {
+ #ifdef HAVE_UNIXD
+- return unixd_config.user_id;
++#if defined(APACHE24)
++ return ap_unixd_config.user_id;
++#else
++ return unixd_config.user_id;
++#endif
+ #else
+ return ap_user_id;
+ #endif
+@@ -396,7 +400,11 @@
+ apache_get_groupid ()
+ {
+ #ifdef HAVE_UNIXD
+- return unixd_config.group_id;
++#if defined(APACHE24)
++ return ap_unixd_config.user_id;
++#else
++ return unixd_config.user_id;
++#endif
+ #else
+ return ap_group_id;
+ #endif
+@@ -406,7 +414,11 @@
+ apache_get_username ()
+ {
+ #ifdef HAVE_UNIXD
++#if defined(APACHE24)
++ return ap_unixd_config.user_name;
++#else
+ return unixd_config.user_name;
++#endif
+ #else
+ return ap_user_name;
+ #endif
+@@ -485,8 +497,12 @@
+
+ #if defined (AP_NEED_SET_MUTEX_PERMS) && defined (HAVE_UNIXD)
+ DEBUG_PRINT (1, "Setting mutex permissions for %s", xsp->dashboard_lock_file);
++#if defined(APACHE24)
++ rv = ap_unixd_set_global_mutex_perms (xsp->dashboard_mutex);
++#else
+ rv = unixd_set_global_mutex_perms (xsp->dashboard_mutex);
+- if (rv != APR_SUCCESS) {
++#endif
++ if (rv != APR_SUCCESS) {
+ ap_log_error (APLOG_MARK, APLOG_CRIT, STATCODE_AND_SERVER (rv),
+ "Failed to set mutex permissions for %s",
+ xsp->dashboard_lock_file);
+@@ -850,10 +866,14 @@
+ #if defined(APACHE22)
+ return c->remote_addr->port;
+ #else
++#if defined(APACHE24)
++ return c->client_addr->port;
++#else
+ apr_port_t port;
+ apr_sockaddr_port_get (&port, c->remote_addr);
+ return port;
+ #endif
++#endif
+
+ }
+
+@@ -863,10 +883,14 @@
+ #if defined(APACHE22)
+ return r->connection->local_addr->port;
+ #else
++#if defined(APACHE24)
++ return r->connection->local_addr->port;
++#else
+ apr_port_t port;
+ apr_sockaddr_port_get (&port, r->connection->local_addr);
+ return port;
+ #endif
++#endif
+ }
+
+ static const char *
+@@ -1977,9 +2001,12 @@
+ size += info.local_ip_len + sizeof (int32_t);
+
+ size += sizeof (int32_t);
+-
+- info.remote_ip_len = strlen (r->connection->remote_ip);
+- size += info.remote_ip_len + sizeof (int32_t);
++#if defined(APACHE24)
++ info.remote_ip_len = strlen (r->connection->client_ip);
++#else
++ info.remote_ip_len = strlen (r->connection->remote_ip);
++#endif
++ size += info.remote_ip_len + sizeof (int32_t);
+
+ size += sizeof (int32_t);
+
+@@ -2026,7 +2053,11 @@
+ i = LE_FROM_INT (i);
+ memcpy (ptr, &i, sizeof (i));
+ ptr += sizeof (int32_t);
++#if defined(APACHE24)
++ ptr += write_string_to_buffer (ptr, 0, r->connection->client_ip, info.remote_ip_len);
++#else
+ ptr += write_string_to_buffer (ptr, 0, r->connection->remote_ip, info.remote_ip_len);
++#endif
+ i = connection_get_remote_port (r->connection);
+ i = LE_FROM_INT (i);
+ memcpy (ptr, &i, sizeof (i));
+Sólo en mod_mono-2.10.new/src: mod_mono.c.orig