summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-26 13:41:00 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-26 13:42:39 +0100
commit04d952e38b62d54dbf4ef7c51d53d80d0040d581 (patch)
tree196568b299c1529106ffdfa988d1dc3f1abd1d61 /www-apache/mod_qos/mod_qos-11.61.ebuild
parentapp-admin/radmind: Bump to 1.15.1 (diff)
downloadgentoo-04d952e38b62d54dbf4ef7c51d53d80d0040d581.tar.gz
gentoo-04d952e38b62d54dbf4ef7c51d53d80d0040d581.tar.bz2
gentoo-04d952e38b62d54dbf4ef7c51d53d80d0040d581.zip
www-apache/mod_qos: Bump to 11.61
Closes: https://bugs.gentoo.org/675716 Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'www-apache/mod_qos/mod_qos-11.61.ebuild')
-rw-r--r--www-apache/mod_qos/mod_qos-11.61.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/www-apache/mod_qos/mod_qos-11.61.ebuild b/www-apache/mod_qos/mod_qos-11.61.ebuild
new file mode 100644
index 000000000000..b7bb23e76819
--- /dev/null
+++ b/www-apache/mod_qos/mod_qos-11.61.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools apache-module
+
+DESCRIPTION="A QOS module for the apache webserver"
+HOMEPAGE="http://mod-qos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mod-qos/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libpcre:3
+ dev-libs/openssl:0=
+ media-libs/libpng:0=
+ sys-libs/zlib:0=
+"
+DEPEND="${DEPEND}"
+
+APXS2_S="${S}/apache2"
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="QOS"
+DOCFILES="${S}/doc/*.txt ${S}/README.TXT"
+
+need_apache2
+
+src_prepare() {
+ cd "${S}/tools" && eautoreconf
+}
+
+src_configure() {
+ cd "${S}/tools" && econf
+}
+
+src_compile() {
+ apache-module_src_compile
+ emake -C "${S}/tools"
+}
+
+src_install() {
+ einfo "Installing Apache module ..."
+ cd "${S}/tools"
+ apache-module_src_install
+
+ einfo "Installing module utilities ..."
+ emake -C "${S}/tools" install DESTDIR="${D}"
+
+ # installing html documentation
+ dohtml -r -x *.txt "${S}/doc/"
+}