summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apache/mpm_itk/mpm_itk-2.4.7_p2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apache/mpm_itk/mpm_itk-2.4.7_p2.ebuild')
-rw-r--r--www-apache/mpm_itk/mpm_itk-2.4.7_p2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apache/mpm_itk/mpm_itk-2.4.7_p2.ebuild b/www-apache/mpm_itk/mpm_itk-2.4.7_p2.ebuild
new file mode 100644
index 000000000000..b54468bc2afb
--- /dev/null
+++ b/www-apache/mpm_itk/mpm_itk-2.4.7_p2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit apache-module linux-info
+
+MY_PN=${PN/_/-}
+MY_PV=${PV/_p/-0}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="Run virtual hosts under separate users/groups"
+HOMEPAGE="http://mpm-itk.sesse.net/"
+SRC_URI="http://mpm-itk.sesse.net/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+# The libcap dependency is automagic, so we require it
+# unconditionally. Reported upstream at,
+#
+# http://lists.err.no/pipermail/mpm-itk/2014-May/000808.html
+#
+#
+# The -threads USE dependency is only reliable as long as we don't
+# support building more than one MPM. See bug #511658.
+#
+DEPEND="sys-libs/libcap
+ >=www-servers/apache-2.4.7[-threads]"
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="00_${PN}"
+APACHE2_MOD_DEFINE="MPM_ITK"
+APXS2_ARGS="-c ${PN}.c seccomp.c -lcap"
+need_apache2_4
+
+pkg_setup() {
+ CONFIG_CHECK="~SECCOMP"
+ linux-info_pkg_setup
+
+ local minkv="3.5"
+ if kernel_is -lt ${minkv//./ }; then
+ ewarn "A kernel newer than ${minkv} (with seccomp v2) is needed"
+ ewarn "for LimitUIDRange and LimitGIDRange which we include by"
+ ewarn "default in ${APACHE2_MOD_CONF}.conf."
+ fi
+}