summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-11 04:19:43 +0000
committerSam James <sam@gentoo.org>2021-03-11 04:19:50 +0000
commit9f513ee89c046aef6ca3c6f43ec999da0d2b4946 (patch)
tree65177a2151b07e9bc3df96f07cee5007b60a7c4e /www-apache
parentnet-analyzer/wireshark: add 3.4.4 (diff)
downloadgentoo-9f513ee89c046aef6ca3c6f43ec999da0d2b4946.tar.gz
gentoo-9f513ee89c046aef6ca3c6f43ec999da0d2b4946.tar.bz2
gentoo-9f513ee89c046aef6ca3c6f43ec999da0d2b4946.zip
www-apache/mod_fastcgi_handler: update EAPI 6 -> 7, fix apache workaround
Thanks-to: Thomas Deutschmann <whissi@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild
index 140492bd2770..fb9676278d0d 100644
--- a/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild
+++ b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit apache-module
@@ -12,7 +12,6 @@ SRC_URI="https://github.com/hollow/mod_fastcgi_handler/archive/v${PV}.tar.gz ->
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
APACHE2_MOD_CONF="20_${PN}"
APACHE2_MOD_DEFINE="FASTCGI_HANDLER"
@@ -21,10 +20,9 @@ APXS2_ARGS="-o ${PN}.so -c *.c"
need_apache2
-src_install() {
+pkg_setup() {
# bug #653606
# but true cause seems to be bug #616612
- APACHE_BASEDIR="/usr/$(get_libdir)/apache2"
- APACHE_MODULESDIR="${APACHE_BASEDIR}/modules"
- default
+ _init_apache2
+ _init_apache2_late
}