summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/b2evolution/b2evolution-4.1.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/b2evolution/b2evolution-4.1.7.ebuild')
-rw-r--r--www-apps/b2evolution/b2evolution-4.1.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/b2evolution/b2evolution-4.1.7.ebuild b/www-apps/b2evolution/b2evolution-4.1.7.ebuild
new file mode 100644
index 000000000000..60278d8c608e
--- /dev/null
+++ b/www-apps/b2evolution/b2evolution-4.1.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp eutils
+
+MY_EXT="stable-2013-04-27"
+MY_PV=${PV/_/-}
+
+DESCRIPTION="Multilingual multiuser multi-blog engine"
+HOMEPAGE="http://www.b2evolution.net"
+SRC_URI="mirror://sourceforge/evocms/${PN}-${MY_PV}-${MY_EXT}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="virtual/httpd-php
+ dev-lang/php[ctype,curl,mysql,tokenizer,xml]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r blogs/*
+
+ rm doc/*.*-*.html doc/*.src.html
+ dohtml doc/*.html
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/conf/_basic_config.template.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/{cache,media}/
+ webapp_configfile
+ "${MY_HTDOCSDIR}"/conf/_{basic_config.template,advanced,locales,formatting,admin,stats,application,config,icons,upgrade}.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}