summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2018-06-26 17:08:40 -0700
committerZac Medico <zmedico@gentoo.org>2018-06-26 17:11:46 -0700
commit157dc868a0b7a933626382701a0dba6e74000bde (patch)
tree053b18f098b9b2e5cc2cc06e326c47d599ae30d2 /www-apps/chromedriver-bin/chromedriver-bin-2.30-r1.ebuild
parentdev-python/selenium: version bump to 3.13.0 (diff)
downloadgentoo-157dc868a0b7a933626382701a0dba6e74000bde.tar.gz
gentoo-157dc868a0b7a933626382701a0dba6e74000bde.tar.bz2
gentoo-157dc868a0b7a933626382701a0dba6e74000bde.zip
www-apps/chromedriver-bin: block www-client/chromium (bug 649742)
Both packages install /usr/bin/chromedriver. Closes: https://bugs.gentoo.org/649742 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-apps/chromedriver-bin/chromedriver-bin-2.30-r1.ebuild')
-rw-r--r--www-apps/chromedriver-bin/chromedriver-bin-2.30-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/www-apps/chromedriver-bin/chromedriver-bin-2.30-r1.ebuild b/www-apps/chromedriver-bin/chromedriver-bin-2.30-r1.ebuild
new file mode 100644
index 000000000000..20c77c77d886
--- /dev/null
+++ b/www-apps/chromedriver-bin/chromedriver-bin-2.30-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="WebDriver for Chrome"
+HOMEPAGE="https://sites.google.com/a/chromium.org/chromedriver"
+SRC_URI="amd64? ( https://chromedriver.storage.googleapis.com/${PV}/chromedriver_linux64.zip -> ${P}.linux64.zip )
+ x86? ( https://chromedriver.storage.googleapis.com/${PV}/chromedriver_linux32.zip -> ${P}.linux32.zip )"
+
+LICENSE="google-chrome"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="!www-client/chromium
+ www-client/google-chrome"
+
+S="${WORKDIR}"
+QA_PREBUILT="usr/bin/chromedriver"
+
+src_install()
+{
+ dobin chromedriver
+}