summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2018-11-28 18:40:06 +0100
committerVirgil Dupras <vdupras@gentoo.org>2018-12-05 20:06:02 -0500
commit71c1797a48ef1d612091642a18e6b9cafe60346f (patch)
treea9098e20d4e5c6cd71374af21f659a37a0b9be7a /www-apps/davical
parentmedia-libs/mesa: Version bump to 18.3.0_rc6 (diff)
downloadgentoo-71c1797a48ef1d612091642a18e6b9cafe60346f.tar.gz
gentoo-71c1797a48ef1d612091642a18e6b9cafe60346f.tar.bz2
gentoo-71c1797a48ef1d612091642a18e6b9cafe60346f.zip
www-apps/davical: fix php4 style constructors
Closes: https://bugs.gentoo.org/650926 Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Till Schäfer <till2.schaefer@uni-dortmund.de> Closes: https://github.com/gentoo/gentoo/pull/10513 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Diffstat (limited to 'www-apps/davical')
-rw-r--r--www-apps/davical/davical-1.1.7-r1.ebuild61
-rw-r--r--www-apps/davical/files/davical-1.1.7-fix_php4_style_constructors.patch39
2 files changed, 100 insertions, 0 deletions
diff --git a/www-apps/davical/davical-1.1.7-r1.ebuild b/www-apps/davical/davical-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..305023b842fc
--- /dev/null
+++ b/www-apps/davical/davical-1.1.7-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="A CalDAV and CardDAV Server"
+HOMEPAGE="https://davical.org/"
+SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-php/awl-0.59
+ sys-devel/gettext"
+RDEPEND="app-admin/pwgen
+ dev-lang/php:*[calendar,curl,pdo,postgres,xml]
+ dev-perl/DBD-Pg
+ dev-perl/DBI
+ dev-perl/YAML
+ >=dev-php/awl-0.59
+ virtual/httpd-php"
+
+need_httpd
+
+PATCHES=( "${FILESDIR}/${P}-fix_php4_style_constructors.patch" )
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake built-locale
+}
+
+src_install() {
+ webapp_src_preinst
+
+ einstalldocs
+
+ einfo "Installing web files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/. htdocs/.htaccess
+
+ einfo "Installing main files and i18n"
+ insinto "${MY_HOSTROOTDIR}/${PN}"
+ doins -r inc locale
+ rm "${ED}/${MY_HOSTROOTDIR}/${PN}/inc/always.php.in" || die
+
+ einfo "Installing sql files"
+ insinto "${MY_SQLSCRIPTSDIR}"
+ doins -r dba/.
+
+ insinto /etc/${PN}
+ doins -r config/. "${FILESDIR}/vhost-example"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+ webapp_src_install
+
+ fperms +x "${MY_SQLSCRIPTSDIR}/create-database.sh"
+ fperms +x "${MY_SQLSCRIPTSDIR}/update-davical-database"
+}
diff --git a/www-apps/davical/files/davical-1.1.7-fix_php4_style_constructors.patch b/www-apps/davical/files/davical-1.1.7-fix_php4_style_constructors.patch
new file mode 100644
index 000000000000..a236e2823373
--- /dev/null
+++ b/www-apps/davical/files/davical-1.1.7-fix_php4_style_constructors.patch
@@ -0,0 +1,39 @@
+diff --git a/inc/HTTPAuthSession.php b/inc/HTTPAuthSession.php
+index e3b208c6..08663286 100644
+--- a/inc/HTTPAuthSession.php
++++ b/inc/HTTPAuthSession.php
+@@ -60,7 +60,7 @@ class HTTPAuthSession {
+ /**
+ * The constructor, which just calls the type supplied or configured
+ */
+- function HTTPAuthSession() {
++ function __construct() {
+ global $c;
+
+ if ( ! empty($_SERVER['PHP_AUTH_DIGEST'])) {
+diff --git a/inc/PublicSession.php b/inc/PublicSession.php
+index 28e06173..e779a9df 100644
+--- a/inc/PublicSession.php
++++ b/inc/PublicSession.php
+@@ -59,7 +59,7 @@ class PublicSession {
+ /**
+ * The constructor, which just calls the actual type configured
+ */
+- function PublicSession() {
++ function __construct() {
+ global $c;
+
+ $principal = new Principal('username','unauthenticated');
+diff --git a/inc/caldav-client.php b/inc/caldav-client.php
+index 4c1bf67f..b32c5c91 100644
+--- a/inc/caldav-client.php
++++ b/inc/caldav-client.php
+@@ -48,7 +48,7 @@ class CalDAVClient {
+ * @param string $pass The password for that user
+ * @param string $calendar The name of the calendar (not currently used)
+ */
+- function CalDAVClient( $base_url, $user, $pass, $calendar = '' ) {
++ function __construct( $base_url, $user, $pass, $calendar = '' ) {
+ $this->user = $user;
+ $this->pass = $pass;
+ $this->calendar = $calendar;