summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-12-19 12:52:19 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-12-19 12:54:50 -0100
commite3606a83d638488f83ca481fee71f7bc420f18cf (patch)
treeaa0d08a346ed140c500711b38f2c175bba85f7ab /www-apps/drupal/drupal-7.69.ebuild
parentdev-ml/seq: fix dependency (diff)
downloadgentoo-e3606a83d638488f83ca481fee71f7bc420f18cf.tar.gz
gentoo-e3606a83d638488f83ca481fee71f7bc420f18cf.tar.bz2
gentoo-e3606a83d638488f83ca481fee71f7bc420f18cf.zip
www-apps/drupal: Security updates (SA-CORE-2019-0{09,10,11,12}).
Security bump to releases 7.69, 8.7.11 and 8.8.1. Bug: https://bugs.gentoo.org/703332 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps/drupal/drupal-7.69.ebuild')
-rw-r--r--www-apps/drupal/drupal-7.69.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/www-apps/drupal/drupal-7.69.ebuild b/www-apps/drupal/drupal-7.69.ebuild
new file mode 100644
index 000000000000..da5fce8597f4
--- /dev/null
+++ b/www-apps/drupal/drupal-7.69.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}