summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-03-16 08:07:21 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-03-16 08:07:21 +0200
commit5437d95c9003ecbbb40c6546ed1c3f4de3153034 (patch)
tree89cd1b3250e0de08e288b9f0c4ae2862bad8e264 /www-apps/drupal
parentwww-apps/drupal: drop 9.5.2 (diff)
downloadgentoo-5437d95c9003ecbbb40c6546ed1c3f4de3153034.tar.gz
gentoo-5437d95c9003ecbbb40c6546ed1c3f4de3153034.tar.bz2
gentoo-5437d95c9003ecbbb40c6546ed1c3f4de3153034.zip
www-apps/drupal: add 10.0.5
Security update. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-10.0.5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 733276664fc9..f9489ec1f050 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,5 @@
DIST drupal-10.0.2.tar.gz 17411661 BLAKE2B c7a9a98f1e8c120486c1a6bd17986b3e99c1e51113969413eb557f657fa3415f65b819a70d08be7c543b6609cba2881b18fa69ce77fe8b3764d9a4a12f569e04 SHA512 19f3f2459c8d2d54647f43db614cd493cb6f068d107678bb6c36823407fe815db71b7919fe755f40fb10c3697afb07e20c93fe47098de88f9248f18cf901da80
+DIST drupal-10.0.5.tar.gz 17424348 BLAKE2B 8ccaf40e3e082906c89536ab7b4e5ca02fe7f98becb590e1e9740b2cca56657a9f4f1fc636de014007673ad3001bc1888511bcf645772b8bf514becd0cf6a9de SHA512 650c45e285fd805e1d311881c66485c407b2f4b3aa9a379893f226d55e7be978c3ff1c7a0ee061e213a3aab9bff8fddcf1339131454d6b29d5c8a03936124362
DIST drupal-7.95.tar.gz 3380331 BLAKE2B 03b7434ef323cd8c26349ae11b65835a30dfb131f5fea36b6ec856d77a57756886fca79ad4f6ef033ab2716713993dcad331c96f99a5291e9083b8151652aa13 SHA512 7e013adc687ea263ff63eecee876367d5a2e4467a44fc4cc0d14a54f82d21b66069aa0ef7123370cdaf0d051a6c2fc870f359d2f2d657a59b41506e7dec8ad84
DIST drupal-9.4.12.tar.gz 21629697 BLAKE2B ffade207c552cbcdc02bfdee672a6f628bb74dbc1bf3e6f276482c838559a7fa195e1c919da6119bdd1edce3b2032ecfb2a9c6694e8894035b22640011d9d92a SHA512 a4e09dbdc6255a82a5948f30f458ed89a0e930703830023116627097f12c2e27c4b0c42feaec21c89db791976a5bd4d2c05d9c02a710384fe4978489ceb78954
DIST drupal-9.5.5.tar.gz 22560005 BLAKE2B 5a79e0d20273e59e1ad88039fb263fa68397d51bc6f614db8e6396d24169cd7b8314e4a0e26f558a0d8a421b0089210c68a26cac3a0d0205421fde52efd4e6f1 SHA512 d965f5e251bc9eb6f392455724b6321ac3c0e6d134ffbff208748aca397dc98c8ff97d2e1ff2369bf97ba8c9416fc0c5d779b33a194af16343ebc584a8cade68
diff --git a/www-apps/drupal/drupal-10.0.5.ebuild b/www-apps/drupal/drupal-10.0.5.ebuild
new file mode 100644
index 000000000000..6a27404d4a84
--- /dev/null
+++ b/www-apps/drupal/drupal-10.0.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+# upstream supports php 8.1+, but dev-php/pecl-uploadprogress does not have 8.2
+# limit php to 8.1 for now
+RDEPEND="
+ dev-lang/php:8.1[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress[php_targets_php8-1] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.md core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt \
+ core/USAGE.txt "
+
+ dodoc ${docs}
+ rm ${docs} core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-10 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}