summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-04-19 21:26:48 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-04-19 21:26:48 +0300
commita3057ad05d24d2bf56565d5142ccc67752ba74be (patch)
tree3ab018572b2800d946e5c872cedfb415ffd3b86b /www-apps/drupal
parentwww-apps/drupal: drop 9.5.5 (diff)
downloadgentoo-a3057ad05d24d2bf56565d5142ccc67752ba74be.tar.gz
gentoo-a3057ad05d24d2bf56565d5142ccc67752ba74be.tar.bz2
gentoo-a3057ad05d24d2bf56565d5142ccc67752ba74be.zip
www-apps/drupal: add 10.0.8
Bug: https://bugs.gentoo.org/904675 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-10.0.8.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 90e0bd17e8e6..0721c42be0eb 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,5 @@
DIST drupal-10.0.5.tar.gz 17424348 BLAKE2B 8ccaf40e3e082906c89536ab7b4e5ca02fe7f98becb590e1e9740b2cca56657a9f4f1fc636de014007673ad3001bc1888511bcf645772b8bf514becd0cf6a9de SHA512 650c45e285fd805e1d311881c66485c407b2f4b3aa9a379893f226d55e7be978c3ff1c7a0ee061e213a3aab9bff8fddcf1339131454d6b29d5c8a03936124362
+DIST drupal-10.0.8.tar.gz 17433029 BLAKE2B 8fbdb7ca86decea007ecd369f5f9c9c9a751ee56df9db5ce117be2cba8d3d82f09994344590be1d3ce690fa747d4a59cf3c04f7427ee531f322d0ecaab5a1a7a SHA512 e1fccce448019b3cfb3a08d0fdd6e6f3ff4ce5110c51393e5c99242e1250e25a647029e4c69600f0e52da8585ae2dcb53804de860fde952928e07b694a61a070
DIST drupal-7.96.tar.gz 3381093 BLAKE2B 5b9468cf1805697649f7414695f1dda3e1f79bdd89213367f86b5c2722a3b6c96f9eb225871ce86ccef246eebbad54fc895761c6fe3e8480ca31f2bbd399aedf SHA512 50904f98bf090c3c6d77fa962f9b64c0b0506584337af0ae3ca964f3216a884cb7597f85c209496777390c97fd010fc888bb5d1db4ee08748dc79a37bef14dc6
DIST drupal-9.4.14.tar.gz 21636221 BLAKE2B e09ae96efb6037be6c9ebcc6785eef6c75cae2988f41aec8c76c761259beb45063ed013f9e5680d1059f0c3051926f08adfc524266e35948814ccb0ca2492806 SHA512 84df434ffaa35b2ef8aef877196732f1038f47e2028091c3b7de47c686f8767ad091573fee531c9d765064b33b94d727258c390c4159d106ef2cbd6e186423f1
DIST drupal-9.5.8.tar.gz 22577412 BLAKE2B f0f372aa4af0356f22e8c37a16b68ae572382f63a0eb030b5a2331d61489769ecf1a99e0428b95f242d725d7125d82857df27c166d599da18b09f1c64fba48c0 SHA512 bb5d1441319d5fb15838535c2af66087ebf7a87f5f91d5a3ef33f74d92104846a8183bce1404b48454d49ff19d5b9afeef0e4bc790c1ac43e5d404fbf927361e
diff --git a/www-apps/drupal/drupal-10.0.8.ebuild b/www-apps/drupal/drupal-10.0.8.ebuild
new file mode 100644
index 000000000000..6a27404d4a84
--- /dev/null
+++ b/www-apps/drupal/drupal-10.0.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+# upstream supports php 8.1+, but dev-php/pecl-uploadprogress does not have 8.2
+# limit php to 8.1 for now
+RDEPEND="
+ dev-lang/php:8.1[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress[php_targets_php8-1] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.md core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt \
+ core/USAGE.txt "
+
+ dodoc ${docs}
+ rm ${docs} core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-10 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}