summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-02-08 15:49:24 +0000
committerSam James <sam@gentoo.org>2022-02-09 11:19:09 +0000
commit9b662725b7c5cd6216b1839f0b9c88ecefc6fb4b (patch)
tree3fb1b84082366e54cc0b7e3b64ee566a14b5e515 /www-apps/gitea
parentmedia-sound/drumstick: bump to 2.5.1 (diff)
downloadgentoo-9b662725b7c5cd6216b1839f0b9c88ecefc6fb4b.tar.gz
gentoo-9b662725b7c5cd6216b1839f0b9c88ecefc6fb4b.tar.bz2
gentoo-9b662725b7c5cd6216b1839f0b9c88ecefc6fb4b.zip
www-apps/gitea: security bump to 1.16.1
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apps/gitea')
-rw-r--r--www-apps/gitea/Manifest1
-rw-r--r--www-apps/gitea/gitea-1.16.1.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/www-apps/gitea/Manifest b/www-apps/gitea/Manifest
index 5c3a70285c4f..1a204d7744f6 100644
--- a/www-apps/gitea/Manifest
+++ b/www-apps/gitea/Manifest
@@ -1,2 +1,3 @@
DIST gitea-1.15.11.tar.gz 48782819 BLAKE2B 1f04314cef3ee1467ed0948e95dec89c75a45cc2c3de78f7fc998b9716c5859bd87ec51e6e2b79d048701ac82fc112b3239a6e27bccfe4b0eeb4cdfdc1fb99d6 SHA512 1f842b90997cb7463751a0e08d37f4823437094efadeb6a27a6bbdb502b2bf33ebb0eab1e8e6bf5b64790b4c513cc42b978ec54152f1a4bfe0b6b957cb179fde
DIST gitea-1.16.0.tar.gz 49689929 BLAKE2B d6713dd6c72ee659335f263bcde2bbf25beba44fda7dc5e31d30c1a24bcf6a9155909f2e8e8039f462a2982ddef235a57cb08d77676c9a139fe5f7ef4379bfa8 SHA512 24cb3d7859bf57a0d78ed7820b1daffda3095fd6025e886d828d956fd1a75e179bd6c784cd54c7f174d63353f68d59c7a2a76cb0ce0a209f6d11b3c3181f9b5e
+DIST gitea-1.16.1.tar.gz 49719355 BLAKE2B a25f421079aa62311e1c607167904fa1daa8208d878fee3fb20cc2954a53ec171189c6d36da486636a725502a2d759534407b1e236e56f4947211c33176204b1 SHA512 c4ec0d1b3ec1898fa72fd62d98555e35898649d29e52eb5b9f9923f9703cd42b1c67f1a1e1a927c3de9b44cd65229c31330e534ad0117633b0320c1434614cab
diff --git a/www-apps/gitea/gitea-1.16.1.ebuild b/www-apps/gitea/gitea-1.16.1.ebuild
new file mode 100644
index 000000000000..eaeda1a3f382
--- /dev/null
+++ b/www-apps/gitea/gitea-1.16.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 2016-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps go-module tmpfiles systemd
+
+DESCRIPTION="A painless self-hosted Git service"
+HOMEPAGE="https://gitea.io https://github.com/go-gitea/gitea"
+SRC_URI="https://github.com/go-gitea/gitea/releases/download/v${PV}/gitea-src-${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~arm64"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="+acct pam sqlite"
+
+DEPEND="
+ acct? (
+ acct-group/git
+ acct-user/git[gitea] )
+ pam? ( sys-libs/pam )"
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+
+DOCS=(
+ custom/conf/app.example.ini CONTRIBUTING.md README.md
+)
+FILECAPS=(
+ -m 711 cap_net_bind_service+ep usr/bin/gitea
+)
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ local sedcmds=(
+ -e "s#^ROOT =#ROOT = ${EPREFIX}/var/lib/gitea/gitea-repositories#"
+ -e "s#^ROOT_PATH =#ROOT_PATH = ${EPREFIX}/var/log/gitea#"
+ -e "s#^APP_DATA_PATH = data#APP_DATA_PATH = ${EPREFIX}/var/lib/gitea/data#"
+ -e "s#^HTTP_ADDR = 0.0.0.0#HTTP_ADDR = 127.0.0.1#"
+ -e "s#^MODE = console#MODE = file#"
+ -e "s#^LEVEL = Trace#LEVEL = Info#"
+ -e "s#^LOG_SQL = true#LOG_SQL = false#"
+ -e "s#^DISABLE_ROUTER_LOG = false#DISABLE_ROUTER_LOG = true#"
+ )
+
+ sed -i "${sedcmds[@]}" custom/conf/app.example.ini || die
+ if use sqlite ; then
+ sed -i -e "s#^DB_TYPE = .*#DB_TYPE = sqlite3#" custom/conf/app.example.ini || die
+ fi
+}
+
+src_compile() {
+ local gitea_tags=(
+ bindata
+ $(usev pam)
+ $(usex sqlite 'sqlite sqlite_unlock_notify' '')
+ )
+ local gitea_settings=(
+ "-X code.gitea.io/gitea/modules/setting.CustomConf=${EPREFIX}/etc/gitea/app.ini"
+ "-X code.gitea.io/gitea/modules/setting.CustomPath=${EPREFIX}/var/lib/gitea/custom"
+ "-X code.gitea.io/gitea/modules/setting.AppWorkPath=${EPREFIX}/var/lib/gitea"
+ )
+ local makeenv=(
+ DRONE_TAG="${PV}"
+ LDFLAGS="-extldflags \"${LDFLAGS}\" ${gitea_settings[*]}"
+ TAGS="${gitea_tags[*]}"
+ )
+
+ env "${makeenv[@]}" emake backend
+}
+
+src_install() {
+ dobin gitea
+
+ einstalldocs
+
+ newconfd "${FILESDIR}/gitea.confd-r1" gitea
+ newinitd "${FILESDIR}/gitea.initd-r3" gitea
+ newtmpfiles - gitea.conf <<-EOF
+ d /run/gitea 0755 git git
+ EOF
+ systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
+
+ insinto /etc/gitea
+ newins custom/conf/app.example.ini app.ini
+ if use acct; then
+ fowners root:git /etc/gitea/{,app.ini}
+ fperms g+w,o-rwx /etc/gitea/{,app.ini}
+
+ diropts -m0750 -o git -g git
+ keepdir /var/lib/gitea /var/lib/gitea/custom /var/lib/gitea/data
+ keepdir /var/log/gitea
+ fi
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+ tmpfiles_process gitea.conf
+
+ ewarn "The default JWT signing algorithm changed in 1.15.0 from HS256 (symmetric) to"
+ ewarn "RS256 (asymmetric). Gitea OAuth2 tokens (and potentially client secrets) will"
+ ewarn "need to be regenerated unless you change your JWT_SIGNING_ALGORITHM back to HS256."
+ ewarn "For other breaking changes, see <https://github.com/go-gitea/gitea/releases/tag/v1.15.0>."
+}