summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/horde
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/horde')
-rw-r--r--www-apps/horde/Manifest2
-rw-r--r--www-apps/horde/horde-3.3.11.ebuild36
-rw-r--r--www-apps/horde/horde-3.3.9.ebuild36
-rw-r--r--www-apps/horde/metadata.xml11
4 files changed, 85 insertions, 0 deletions
diff --git a/www-apps/horde/Manifest b/www-apps/horde/Manifest
new file mode 100644
index 000000000000..5e3f8d3bfab0
--- /dev/null
+++ b/www-apps/horde/Manifest
@@ -0,0 +1,2 @@
+DIST horde-3.3.11.tar.gz 8788320 RMD160 e5e80e47a564b69e8e5db8648614a4fc6f6e06fd SHA1 66710a5026d78e462422969b187e78ff52b04e34 SHA256 abc8f01f33655767303b70da44c90117f95ae37838e0371b46218e375eb7a760
+DIST horde-3.3.9.tar.gz 8848371 RMD160 cfcc418b8744c006a36ae573f82bb1937f489c3a SHA1 0633c9710a543e9d284c204aee15c223bc2ada51 SHA256 0c44beb11945d1f9032ad3ae041121ef1b67377cdda20bb8e11602b352641f77
diff --git a/www-apps/horde/horde-3.3.11.ebuild b/www-apps/horde/horde-3.3.11.ebuild
new file mode 100644
index 000000000000..137312bed2a8
--- /dev/null
+++ b/www-apps/horde/horde-3.3.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+HORDE_PHP_FEATURES="session xml"
+
+inherit horde
+
+DESCRIPTION="Horde Application Framework"
+HOMEPAGE="http://www.horde.org/"
+
+KEYWORDS="alpha amd64 hppa ~ia64 ppc sparc x86"
+IUSE="mysql"
+
+DEPEND=""
+RDEPEND="dev-lang/php
+ >=sys-devel/gettext-0.10.40
+ >=dev-libs/libxml2-2.4.21
+ >=www-apps/horde-pear-1.3
+ dev-php/PEAR-Log
+ dev-php/PEAR-Mail_Mime
+ mysql? ( dev-php/PEAR-DB )"
+
+src_unpack() {
+ horde_src_unpack
+ cd "${S}"
+ chmod 600 scripts/sql/create.*.sql #137510
+}
+
+pkg_postinst() {
+ horde_pkg_postinst
+ elog "Horde requires PHP to have:"
+ elog " ==> 'short_open_tag enabled = On'"
+ elog " ==> 'magic_quotes_runtime set = Off'"
+ elog " ==> 'file_uploads enabled = On'"
+}
diff --git a/www-apps/horde/horde-3.3.9.ebuild b/www-apps/horde/horde-3.3.9.ebuild
new file mode 100644
index 000000000000..137312bed2a8
--- /dev/null
+++ b/www-apps/horde/horde-3.3.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+HORDE_PHP_FEATURES="session xml"
+
+inherit horde
+
+DESCRIPTION="Horde Application Framework"
+HOMEPAGE="http://www.horde.org/"
+
+KEYWORDS="alpha amd64 hppa ~ia64 ppc sparc x86"
+IUSE="mysql"
+
+DEPEND=""
+RDEPEND="dev-lang/php
+ >=sys-devel/gettext-0.10.40
+ >=dev-libs/libxml2-2.4.21
+ >=www-apps/horde-pear-1.3
+ dev-php/PEAR-Log
+ dev-php/PEAR-Mail_Mime
+ mysql? ( dev-php/PEAR-DB )"
+
+src_unpack() {
+ horde_src_unpack
+ cd "${S}"
+ chmod 600 scripts/sql/create.*.sql #137510
+}
+
+pkg_postinst() {
+ horde_pkg_postinst
+ elog "Horde requires PHP to have:"
+ elog " ==> 'short_open_tag enabled = On'"
+ elog " ==> 'magic_quotes_runtime set = Off'"
+ elog " ==> 'file_uploads enabled = On'"
+}
diff --git a/www-apps/horde/metadata.xml b/www-apps/horde/metadata.xml
new file mode 100644
index 000000000000..1f0aa4dd26bb
--- /dev/null
+++ b/www-apps/horde/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>web-apps</herd>
+<longdescription>
+The Horde Application Framework is a general-purpose web application
+framework in PHP, providing classes for dealing with preferences,
+compression, browser detection, connection tracking, MIME handling, and
+more.
+</longdescription>
+</pkgmetadata>