summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-06-30 17:57:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-06-30 17:57:05 -0500
commitad78aa38a07dcf38d30798dd7c89bddd7ff0d058 (patch)
treea81b413a7d258db6af6f664ba82ca6da30738e13 /www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild
parentnet-misc/radvd: systemd hardening (diff)
downloadgentoo-ad78aa38a07dcf38d30798dd7c89bddd7ff0d058.tar.gz
gentoo-ad78aa38a07dcf38d30798dd7c89bddd7ff0d058.tar.bz2
gentoo-ad78aa38a07dcf38d30798dd7c89bddd7ff0d058.zip
www-apps/icingaweb2-module-director: adding for bug 582568
Package-Manager: portage-2.2.28
Diffstat (limited to 'www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild')
-rw-r--r--www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild b/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild
new file mode 100644
index 000000000000..539cc51bcc14
--- /dev/null
+++ b/www-apps/icingaweb2-module-director/icingaweb2-module-director-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Icinga Web 2 plugin for configuration"
+HOMEPAGE="https://dev.icinga.org/projects/icingaweb2-module-director/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-director.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_PN="icingaweb2-module-director"
+ SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.4.3
+ >=www-apps/icingaweb2-2.2.0
+ || (
+ dev-lang/php:5.6[curl]
+ dev-lang/php:7.0[curl]
+ )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/director/"
+ doins -r "${S}"/*
+}