summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-11-01 16:16:56 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2022-11-01 14:03:28 -0500
commit0417dcdf485ccec0a0d1f5deef3011c33524e71b (patch)
treef96d195314ce68cebe39aab31a40a8661352080d /www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.2.1.ebuild
parentdev-libs/icinga-php-library: add 0.10.0 (diff)
downloadgentoo-0417dcdf485ccec0a0d1f5deef3011c33524e71b.tar.gz
gentoo-0417dcdf485ccec0a0d1f5deef3011c33524e71b.tar.bz2
gentoo-0417dcdf485ccec0a0d1f5deef3011c33524e71b.zip
www-apps/icingaweb2-module-graphite: add 1.2.1
Closes: https://bugs.gentoo.org/879005 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.2.1.ebuild')
-rw-r--r--www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.2.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.2.1.ebuild b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.2.1.ebuild
new file mode 100644
index 000000000000..23db2f2931de
--- /dev/null
+++ b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-1.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Icinga Web 2 plugin for Graphite"
+HOMEPAGE="https://www.icinga.com/docs/graphite/latest/"
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-graphite.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/Icinga/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=net-analyzer/icinga2-2.4.0
+ >=www-apps/icingaweb2-2.5.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/icingaweb2/modules/graphite/"
+ doins -r "${S}"/*
+}