summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-07-28 11:10:46 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-07-28 11:11:54 -0500
commit1596402a82a2502ad87ac44ac68e275db0d089e6 (patch)
tree7ea7ad3e90b91a48ddca4ad26616cc7697af1126 /www-apps/icingaweb2
parentdev-python/cppy: keyworded 1.1.0 for hppa, bug #804118 (diff)
downloadgentoo-1596402a82a2502ad87ac44ac68e275db0d089e6.tar.gz
gentoo-1596402a82a2502ad87ac44ac68e275db0d089e6.tar.bz2
gentoo-1596402a82a2502ad87ac44ac68e275db0d089e6.zip
www-apps/icingaweb2: 2.8.4 and 2.9.1 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'www-apps/icingaweb2')
-rw-r--r--www-apps/icingaweb2/Manifest2
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.8.4.ebuild77
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.9.1.ebuild78
3 files changed, 157 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index b68f250d6c8f..93325f9e88a2 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,3 +1,5 @@
DIST icingaweb2-2.8.2.tar.gz 8514166 BLAKE2B 7e6a44574999967a6a728c5818999ac6f15234f1cfd1415132e1a8219e897affddd4d4ec488bb90ced82a0ce5403220463ccfa0424014a4c090176d85fd968a9 SHA512 252ecb36751add239897b6344dd622542f892b1850398fe724d0ab91e8d691cefe0b33c727c28aa630c93b76b381aabe69721db034c4de0518f346bbd5b698de
DIST icingaweb2-2.8.3.tar.gz 8514052 BLAKE2B 507753833ed8a0de816651f3fdb06f3fdf04b3fa9c43fad5046c28924c93f3c3e491d9a4e1532f08ac0d6abe97c1343b85cdb23de9ece9f16858b91886283e9c SHA512 236385dc54dbd11d8e100059bb7e29b3a4efc23888f187e13e563510dfb1f3d20e5c4107e2dadfa6842e6689aaa21d4e9465abd0a234c52229354f43ec44cfb4
+DIST icingaweb2-2.8.4.tar.gz 8514585 BLAKE2B 1c331d45152a94dcaf21509e36ecd9c90c840f41bf14d102910e65fce28994bb7db3319c39e5d5740638a673c74b84b54d803b97d91cb8968260174b2437a7ca SHA512 7f136f7901db8398fab85fef079d4e5af1662c13c5c107d3c1c10e022186bdca29d3b144f937e40e470975b97bd98215ec3e0c7f2b6127a6a74143fbe0e1882c
DIST icingaweb2-2.9.0.tar.gz 10895850 BLAKE2B cf0f1375e3eb29ddbbf6691afd1c240ae1431b7dd82bd591dd3fe135602d1eabc418c6279fe7bd8f8e519f264b69a9da8bb1d09d286f37aa2f7e5ed21ddacd5a SHA512 d8f2817c025160cd8f59f33d678ca6eea9b893b80ca5c45c719d8778269da46322e720a1c73d7bcd7be73a07f08dbe279ffb78220f2a6c00f7e07e9f0f88d4d4
+DIST icingaweb2-2.9.1.tar.gz 12303053 BLAKE2B aa90b4a9de89dda35d790a002230b14da2b64a155bb6742cb6425a49225fd7b34d0fe84d4184ee6835077c591862df10851ac8ccecf12253694180e455ef0665 SHA512 050eaecd68f40330ed3d1bf044d99af003f1867057c9fb0b51125490135d173ea076dc93c901b656942debc128d893db02e98e207de3b5d16ee3e6bb85f46702
diff --git a/www-apps/icingaweb2/icingaweb2-2.8.4.ebuild b/www-apps/icingaweb2/icingaweb2-2.8.4.ebuild
new file mode 100644
index 000000000000..c5f119e375d9
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.8.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}
diff --git a/www-apps/icingaweb2/icingaweb2-2.9.1.ebuild b/www-apps/icingaweb2/icingaweb2-2.9.1.ebuild
new file mode 100644
index 000000000000..84db9d6e0716
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.9.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit depend.apache multilib
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 apache2-server fpm ldap mysql nginx pdf postgres"
+REQUIRED_USE="( ^^ ( apache2-server nginx ) ) apache2? ( apache2-server )"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2-server? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )
+ || (
+ dev-lang/php:7.3[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.4[apache2?,cli,fpm?,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:8.0[apache2?,cli,fpm?,gd,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ acct-group/icingacmd
+ acct-group/icingaweb2"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}