summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-01-28 09:27:07 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-01-28 09:27:41 -0600
commit4ff186f5a4b20462ab25081ff1080c16245a27ce (patch)
tree2e1d11979118837572aa53ba69b88a1c65c2acb3 /www-apps/icingaweb2
parentsys-devel/gcc-config: Add appropriate gentoo-functions dep (diff)
downloadgentoo-4ff186f5a4b20462ab25081ff1080c16245a27ce.tar.gz
gentoo-4ff186f5a4b20462ab25081ff1080c16245a27ce.tar.bz2
gentoo-4ff186f5a4b20462ab25081ff1080c16245a27ce.zip
www-apps/icingaweb2: adding 9999 version
Package-Manager: portage-2.2.26
Diffstat (limited to 'www-apps/icingaweb2')
-rw-r--r--www-apps/icingaweb2/icingaweb2-9999.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/icingaweb2-9999.ebuild b/www-apps/icingaweb2/icingaweb2-9999.ebuild
new file mode 100644
index 000000000000..17371c75d7a8
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit depend.apache eutils git-2 multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+EGIT_REPO_URI="https://github.com/Icinga/icingaweb2.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx postgres"
+KEYWORDS=""
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-lang/php:*[apache2?,cli,gd,json,intl,ldap?,mysql?,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-php/pecl-imagick
+ apache2? ( >=www-servers/apache-2.4.0 )
+ nginx? ( >=www-servers/nginx-1.7.0:* )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache2
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ mkdir -p "${D}/usr/share/${PN}"
+ cp -R "${S}"/* "${D}/usr/share/${PN}"
+ chmod -R a+rX "${D}/usr/share/${PN}/public"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}