summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-04-27 15:49:11 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-04-27 15:49:51 -0500
commit8957b6666686ccc2c258f4be8d960ee38e11c723 (patch)
tree9f88905e9f6698460b45986c84af99fafda9c572 /www-apps/icingaweb2
parentapp-office/gnucash: Reactivate doc use flag on 3.0 (diff)
downloadgentoo-8957b6666686ccc2c258f4be8d960ee38e11c723.tar.gz
gentoo-8957b6666686ccc2c258f4be8d960ee38e11c723.tar.bz2
gentoo-8957b6666686ccc2c258f4be8d960ee38e11c723.zip
www-apps/icingaweb2: 2.5.3 bup
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'www-apps/icingaweb2')
-rw-r--r--www-apps/icingaweb2/Manifest1
-rw-r--r--www-apps/icingaweb2/icingaweb2-2.5.3.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/www-apps/icingaweb2/Manifest b/www-apps/icingaweb2/Manifest
index 8710b509b4af..0957f7b860ed 100644
--- a/www-apps/icingaweb2/Manifest
+++ b/www-apps/icingaweb2/Manifest
@@ -1,2 +1,3 @@
DIST icingaweb2-2.5.1.tar.gz 8133540 BLAKE2B f5f9d2131f87160f7df5b34cae7e9b1036e14994f3b739607b26ba676e6cd56ad95ed5688c873df3232fc9782566b0bb5c2054aa04dd272b389a1eae8501af88 SHA512 8e76347f76a2b2889fb9a61c000ef7865f40b2ea261f59bfbf24bb8d0e4e7e2977ff283d31989f6892e371f4a9a4d4682a2cac3269070b2036cc37ea74af1b11
DIST icingaweb2-2.5.2.tar.gz 8125051 BLAKE2B 36ed108d890736c909a9aa5908405e864129538801a5648194e976179660841244c53f852badaafcda50b2677abc74afb3b48d2073ef8f80e23a795a65b2a641 SHA512 174bc4b2433f49cc9e58dc2501b9328520914d7eebb81193950e5fe337620f3fbf345a0537176fbfc1dbc062f9cb7e1e4e3058480bad5b73f465fb8e1839e90d
+DIST icingaweb2-2.5.3.tar.gz 8124667 BLAKE2B 43f9e47d670aaeffb15a8dbca6794d72436b195d4a19491d31f548a57ef9d2d0c411f16276be5355700e8dc863b8ef84821c68759d65ef2e97688a88d92605ca SHA512 d11d4f90f0cb54ab6fc5412151d412fc7827c895e81f6c91806090c364b3df4f2999bbc5f65cd4007406a3e7a7c9e0d48fb8f8362f3d7780681ac8702cfcb572
diff --git a/www-apps/icingaweb2/icingaweb2-2.5.3.ebuild b/www-apps/icingaweb2/icingaweb2-2.5.3.ebuild
new file mode 100644
index 000000000000..f3513d784a28
--- /dev/null
+++ b/www-apps/icingaweb2/icingaweb2-2.5.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit depend.apache eutils multilib user
+
+DESCRIPTION="Icinga Web 2 - Frontend for icinga2"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://codeload.github.com/Icinga/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="apache2 ldap mysql nginx pdf postgres"
+REQUIRED_USE="^^ ( apache2 nginx )"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=net-analyzer/icinga2-2.1.1
+ dev-php/pecl-imagick
+ pdf? ( media-gfx/imagemagick[png] )
+ apache2? (
+ >=www-servers/apache-2.4.0
+ || (
+ dev-lang/php:5.6[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )
+ nginx? (
+ >=www-servers/nginx-1.7.0:*
+ || (
+ dev-lang/php:5.6[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.0[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ dev-lang/php:7.1[apache2?,cli,fpm,gd,json,intl,ldap?,mysql?,nls,pdo,postgres?,sockets,ssl,xslt,xml]
+ )
+ )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+
+ enewgroup icingaweb2
+ enewgroup icingacmd
+ use nginx && usermod -a -G icingacmd,icingaweb2 nginx
+ use apache2 && usermod -a -G icingacmd,icingaweb2 apache
+}
+
+pkg_config() {
+ if [[ -d /etc/icingaweb2 ]] ; then
+ einfo "Updating existing installation ..."
+ else
+ einfo "Running first time setup ..."
+ einfo "Creating configuration directory ..."
+ /usr/share/${PN}/bin/icingacli setup config directory
+ einfo "Creating authentication token for web setup ..."
+ /usr/share/${PN}/bin/icingacli setup token create
+ if use apache2 ; then
+ einfo "The following might be useful for your Apache2 configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver apache --document-root /usr/share/${PN}/public
+ fi
+ if use nginx ; then
+ einfo "The following might be useful for your NGinx configuration:"
+ /usr/share/${PN}/bin/icingacli setup config webserver nginx --document-root /usr/share/${PN}/public
+ fi
+ fi
+ einfo "All done."
+}
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins -r "${S}"/*
+ fperms -R a+rX "/usr/share/${PN}/public/"
+ fperms u+x,g+x "/usr/share/${PN}/bin/icingacli"
+}
+
+pkg_postinst() {
+ einfo "Run 'emerge --config =${CATEGORY}/${PF}' to finish setup."
+}