summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2021-01-25 21:23:01 -0500
committerAaron Bauman <bman@gentoo.org>2021-01-25 21:23:35 -0500
commitc9aadb736ba122fb8a237459dca32a9d0d42ced0 (patch)
tree5bf5a8d860cef4e03c190d2bc2b43ea9794b4484 /www-apps/jekyll
parentdev-python/llfuse: Keyword 1.3.6 arm, #766525 (diff)
downloadgentoo-c9aadb736ba122fb8a237459dca32a9d0d42ced0.tar.gz
gentoo-c9aadb736ba122fb8a237459dca32a9d0d42ced0.tar.bz2
gentoo-c9aadb736ba122fb8a237459dca32a9d0d42ced0.zip
www-apps/jekyll: bump to 4.2.0 and fix tests
* Add missing test deps: ** dev-ruby/kramdown-syntax-coderay ** dev-ruby/nokogiri * There is no missing dependency on bundler and this bug should be fixed in 4.1.1 and in 4.2.0. If not, please re-open. * Add patch for missing dep in gemspec Closes: https://bugs.gentoo.org/625994 Closes: https://bugs.gentoo.org/726072 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'www-apps/jekyll')
-rw-r--r--www-apps/jekyll/Manifest1
-rw-r--r--www-apps/jekyll/files/jekyll-missingdep.patch14
-rw-r--r--www-apps/jekyll/jekyll-4.2.0.ebuild95
3 files changed, 110 insertions, 0 deletions
diff --git a/www-apps/jekyll/Manifest b/www-apps/jekyll/Manifest
index 5b9729c8243d..024159d8adca 100644
--- a/www-apps/jekyll/Manifest
+++ b/www-apps/jekyll/Manifest
@@ -1 +1,2 @@
DIST jekyll-4.1.1.tar.gz 1398438 BLAKE2B ac207d58b155e069fda40b4598d441d8fb88f22e85740082829d018dc9cefe51ca636b23a6207c37711c4d26e078f6e4913946599f0200b8e8cb065a9ceff952 SHA512 98c635b54219c9666de6496e76f3a131fc715d650d868049c0fe10d76851a027e0808609c2dce1a138c95eb2fb7e58ef978237a305484071339b4a15d5acc4d5
+DIST jekyll-4.2.0.tar.gz 1412419 BLAKE2B 351852b52abc227f8e1eedeeef0871a593d66ffc95f4ed644441f81e841582ab9f393b206f049107daa7e9deaa63d36359ff8d0b47c69b629dda2ea462cd0481 SHA512 aee4d832631a285c3d37576b5f3d80073b56afefcb8c8a19a74435ce431b606b5cedc28a02c8e3930f9bc35ab432c952f96e1878b3bee6b9d33fbd01f0a147ec
diff --git a/www-apps/jekyll/files/jekyll-missingdep.patch b/www-apps/jekyll/files/jekyll-missingdep.patch
new file mode 100644
index 000000000000..fcaf8f10e86f
--- /dev/null
+++ b/www-apps/jekyll/files/jekyll-missingdep.patch
@@ -0,0 +1,14 @@
+--- a/jekyll.gemspec 2021-01-26 04:08:18.198289608 +0200
++++ b/jekyll.gemspec 2021-01-26 04:09:08.545548043 +0200
+@@ -41,9 +41,11 @@
+ s.add_runtime_dependency("kramdown", "~> 2.3")
+ s.add_runtime_dependency("kramdown-parser-gfm", "~> 1.0")
+ s.add_runtime_dependency("liquid", "~> 4.0")
++ s.add_runtime_dependency("listen", "~> 3.4")
+ s.add_runtime_dependency("mercenary", "~> 0.4.0")
+ s.add_runtime_dependency("pathutil", "~> 0.9")
+ s.add_runtime_dependency("rouge", "~> 3.0")
+ s.add_runtime_dependency("safe_yaml", "~> 1.0")
+ s.add_runtime_dependency("terminal-table", "~> 2.0")
++
+ end
diff --git a/www-apps/jekyll/jekyll-4.2.0.ebuild b/www-apps/jekyll/jekyll-4.2.0.ebuild
new file mode 100644
index 000000000000..8affdcb77943
--- /dev/null
+++ b/www-apps/jekyll/jekyll-4.2.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="README.markdown History.markdown"
+RUBY_FAKEGEM_EXTRAINSTALL="features"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+DESCRIPTION="A simple, blog aware, static site generator"
+HOMEPAGE="https://jekyllrb.com https://github.com/jekyll/jekyll"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.4
+ >=dev-ruby/colorator-1.0
+ >=dev-ruby/em-websocket-0.5
+ dev-ruby/i18n:1
+ >=dev-ruby/kramdown-2.1:2
+ dev-ruby/kramdown-parser-gfm:1
+ dev-ruby/liquid:4
+ >=dev-ruby/mercenary-0.4.0
+ >=dev-ruby/pathutil-0.9
+ =dev-ruby/rouge-3*
+ >=dev-ruby/safe_yaml-1.0
+ >=dev-ruby/terminal-table-1.8:0
+ >=www-apps/jekyll-sass-converter-2.0
+ >=www-apps/jekyll-watch-2.0
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/classifier-reborn-2.1.0
+ dev-ruby/httpclient
+ dev-ruby/kramdown-syntax-coderay
+ dev-ruby/launchy
+ dev-ruby/nokogiri
+ >=dev-ruby/rdiscount-2.0
+ >=dev-ruby/redcarpet-3.2.3
+ dev-ruby/rspec-mocks
+ >=dev-ruby/shoulda-3
+ dev-ruby/test-unit:2
+ www-apps/jekyll-coffeescript
+ )
+"
+
+all_ruby_prepare() {
+ # reported upstream https://github.com/jekyll/jekyll/issues/8556
+ eapply "${FILESDIR}"/jekyll-missingdep.patch
+ eapply "${FILESDIR}"/jekyll-3.6.0-test-helper.patch
+
+ # Drop tests requiring bundler
+ sed -i -e '/bundle_message/d' test/test_new_command.rb || die
+ rm test/test_plugin_manager.rb || die
+
+ # Replace git command in gemspec
+ sed -e 's/git ls-files/find -not -type d -print/' \
+ -e 's:_relative ": "./:' \
+ -i $RUBY_FAKEGEM_GEMSPEC || die
+
+ # FIXMEs:
+ # fails to find fixtures because this requires bundler
+ rm test/test_theme.rb || die
+ rm test/test_theme_assets_reader.rb || die
+ sed -i -e '/^ should.*theme/,/^ end$/d' \
+ -e '/^ should.*theme/,/^ end$/d' test/test_site.rb || die
+ sed -i -e '/context "with a theme"/,/^ end/ s:^:#:' test/test_layout_reader.rb || die
+ sed -i -e '/normalize paths of rendered items/askip "test-theme"' test/test_liquid_renderer.rb || die
+ # partially requires 'toml'
+ rm test/test_configuration.rb || die
+ # pygments tests fail because of line numbering
+ sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_tags.rb || die
+ #sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_redcarpet.rb || die
+
+ # Tries to use bundler and install packages.
+ rm -f test/test_new_command.rb || die
+}
+
+src_test() {
+ local -x JEKYLL_NO_BUNDLER_REQUIRE=true
+
+ ruby-ng_src_test
+}