summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-01 08:22:46 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-01 08:25:35 +0200
commitcd4aa6ae7a1549cc076e849b8947b1120e7bd796 (patch)
tree8af17c9b61c3e8cd9d5a4dcaf27eda211ffa7ad4 /www-apps/jekyll
parentdev-ruby/mercenary: update EAPI 7 -> 8, add ruby32 (diff)
downloadgentoo-cd4aa6ae7a1549cc076e849b8947b1120e7bd796.tar.gz
gentoo-cd4aa6ae7a1549cc076e849b8947b1120e7bd796.tar.bz2
gentoo-cd4aa6ae7a1549cc076e849b8947b1120e7bd796.zip
www-apps/jekyll: add 4.3.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-apps/jekyll')
-rw-r--r--www-apps/jekyll/Manifest1
-rw-r--r--www-apps/jekyll/jekyll-4.3.2.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/www-apps/jekyll/Manifest b/www-apps/jekyll/Manifest
index fcd44e6a0371..7097fc294848 100644
--- a/www-apps/jekyll/Manifest
+++ b/www-apps/jekyll/Manifest
@@ -1 +1,2 @@
DIST jekyll-4.2.2.tar.gz 1413485 BLAKE2B 08f4b8b72aecc19d5c8d7bd29897d88edb66ce82b172306ee4fe356a5d2598362f3946354eaa3701f14df0f97e7fc95361b5cc59ec8820703c879bcf05e6331a SHA512 3c72a24a2193493c9e417a05a113fa85889abd8df4d4c114fdc082e40de81d24824e3c4e41ecb3633ef780d4e3f3b0ab091c5f4234326a83b1a8a3da543275ff
+DIST jekyll-4.3.2.tar.gz 1447970 BLAKE2B 8f722c363483d937198f5ac1abbca3aa59f754f66106d4355c59da541cce218704ee3976af2842e6b2f58d367eb80caa376612f73c84032ac5a2aa3076f6d007 SHA512 865bffe97683a4765a16b6eb9ec1bbbb5d2567699ad343360e101d3cae81187ea0f218b67d13a1121213fc49269475935fe0322d8b0f052c868536d5aaa0f7ab
diff --git a/www-apps/jekyll/jekyll-4.3.2.ebuild b/www-apps/jekyll/jekyll-4.3.2.ebuild
new file mode 100644
index 000000000000..db9b3c7015a0
--- /dev/null
+++ b/www-apps/jekyll/jekyll-4.3.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="README.markdown History.markdown"
+RUBY_FAKEGEM_EXTRAINSTALL="features"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+DESCRIPTION="A simple, blog aware, static site generator"
+HOMEPAGE="https://jekyllrb.com https://github.com/jekyll/jekyll"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/addressable-2.4
+ >=dev-ruby/colorator-1.0
+ >=dev-ruby/em-websocket-0.5
+ dev-ruby/i18n:1
+ >=dev-ruby/kramdown-2.3:2
+ dev-ruby/kramdown-parser-gfm:1
+ dev-ruby/liquid:4
+ >=dev-ruby/mercenary-0.4.0
+ >=dev-ruby/pathutil-0.9
+ || ( dev-ruby/rouge:4 dev-ruby/rouge:2 )
+ >=dev-ruby/safe_yaml-1.0
+ || ( dev-ruby/terminal-table:3 dev-ruby/terminal-table:2 )
+ >=www-apps/jekyll-sass-converter-2.0
+ >=www-apps/jekyll-watch-2.2.1-r1
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/httpclient
+ dev-ruby/kramdown-syntax-coderay
+ dev-ruby/launchy
+ dev-ruby/nokogiri
+ >=dev-ruby/rdiscount-2.0
+ >=dev-ruby/redcarpet-3.2.3
+ dev-ruby/rspec-mocks
+ >=dev-ruby/shoulda-3
+ dev-ruby/test-unit:2
+ www-apps/jekyll-coffeescript
+ )
+"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}"/jekyll-3.6.0-test-helper.patch
+ eapply -R "${FILESDIR}/${P}-sass.patch"
+
+ # Drop tests requiring bundler
+ sed -i -e '/bundle_message/d' test/test_new_command.rb || die
+ rm test/test_plugin_manager.rb || die
+
+ # Drop tests requiring classifier-reborn (ruby27-only package)
+ rm -f test/test_related_posts.rb || die
+
+ # Replace git command in gemspec
+ sed -e 's/git ls-files/find -not -type d -print/' \
+ -e 's:_relative ": "./:' \
+ -i $RUBY_FAKEGEM_GEMSPEC || die
+
+ # FIXMEs:
+ # fails to find fixtures because this requires bundler
+ rm -f test/test_theme.rb || die
+ rm -f test/test_theme_{assets_reader,data_reader,drop}.rb || die
+ sed -i -e '/^ should.*theme/,/^ end$/d' \
+ -e '/^ should.*theme/,/^ end$/d' test/test_site.rb || die
+ sed -i -e '/context "with a theme"/,/^ end/ s:^:#:' test/test_layout_reader.rb || die
+ sed -i -e '/normalize paths of rendered items/askip "test-theme"' test/test_liquid_renderer.rb || die
+ # partially requires 'toml'
+ rm test/test_configuration.rb || die
+ # pygments tests fail because of line numbering
+ sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_tags.rb || die
+ #sed -i -e '/^ context.*pygments/,/^ end$/d' test/test_redcarpet.rb || die
+
+ # Tries to use bundler and install packages.
+ rm -f test/test_new_command.rb || die
+
+ # Fails due to ordering differences in ruby 3.0
+ sed -e '/convert drop to json/askip "hash ordering with ruby 3"' \
+ -i test/test_filters.rb || die
+
+ # Avoid a test failing due to TZ differences
+ sed -e '/contain the proper page data to mimic the post liquid/askip "TZ difference"' \
+ -i test/test_excerpt.rb || die
+}
+
+src_test() {
+ local -x JEKYLL_NO_BUNDLER_REQUIRE=true
+
+ ruby-ng_src_test
+}