summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-09-19 01:34:32 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-22 15:11:52 +0200
commit9e6c12e33d6e80b977c01af5d4c184df5ddcee07 (patch)
tree75070f1a1259f7c1912315bf3eb60e5fab5f7da2 /www-apps/klaus/klaus-1.2.1.ebuild
parentdev-python/httpauth: add py3.6 and pypy{,3} to PYTHON_COMPAT. (diff)
downloadgentoo-9e6c12e33d6e80b977c01af5d4c184df5ddcee07.tar.gz
gentoo-9e6c12e33d6e80b977c01af5d4c184df5ddcee07.tar.bz2
gentoo-9e6c12e33d6e80b977c01af5d4c184df5ddcee07.zip
www-apps/klaus: version bump to 1.2.1 and add py3.6 to PYTHON_COMPAT.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'www-apps/klaus/klaus-1.2.1.ebuild')
-rw-r--r--www-apps/klaus/klaus-1.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apps/klaus/klaus-1.2.1.ebuild b/www-apps/klaus/klaus-1.2.1.ebuild
new file mode 100644
index 000000000000..ed6095ec5a5f
--- /dev/null
+++ b/www-apps/klaus/klaus-1.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ctags"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.13.0[${PYTHON_USEDEP}]
+ dev-python/httpauth[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ ctags? (
+ dev-python/python-ctags[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# The tests can only be run from a git repository
+# so they are not included in the source distributions