summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-04-20 23:57:55 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-04-21 00:45:48 +0200
commit5fd738261b6b44427702a2ce34f9f4c159d513f7 (patch)
tree2ce8662c631d2347de8bcd42b0c1f93862840e14 /www-apps/klaus/klaus-1.2.2.ebuild
parentdev-python/brython: clean up old versions. (diff)
downloadgentoo-5fd738261b6b44427702a2ce34f9f4c159d513f7.tar.gz
gentoo-5fd738261b6b44427702a2ce34f9f4c159d513f7.tar.bz2
gentoo-5fd738261b6b44427702a2ce34f9f4c159d513f7.zip
www-apps/klaus: version bump.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'www-apps/klaus/klaus-1.2.2.ebuild')
-rw-r--r--www-apps/klaus/klaus-1.2.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/www-apps/klaus/klaus-1.2.2.ebuild b/www-apps/klaus/klaus-1.2.2.ebuild
new file mode 100644
index 000000000000..b5377c3de06f
--- /dev/null
+++ b/www-apps/klaus/klaus-1.2.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ctags"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.13.0[${PYTHON_USEDEP}]
+ dev-python/httpauth[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ ctags? (
+ dev-python/python-ctags[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# The tests can only be run from a git repository
+# so they are not included in the source distributions