summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2016-02-23 21:17:26 -0600
committerDoug Goldstein <cardoe@gentoo.org>2016-02-23 21:20:52 -0600
commit6f7ff4cb5b1dfff4169e53401bd75dfc84283952 (patch)
tree31d79b5e36b6836698c4fb43431ca3c219ea3d2c /www-apps/mythweb
parentnet-analyzer/speedtest-cli: Fix output with Python 3 (diff)
downloadgentoo-6f7ff4cb5b1dfff4169e53401bd75dfc84283952.tar.gz
gentoo-6f7ff4cb5b1dfff4169e53401bd75dfc84283952.tar.bz2
gentoo-6f7ff4cb5b1dfff4169e53401bd75dfc84283952.zip
mythtv: remove older versions
Since the versions are all interdependent its easier to do in one big tree commit. Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'www-apps/mythweb')
-rw-r--r--www-apps/mythweb/Manifest2
-rw-r--r--www-apps/mythweb/mythweb-0.26.0.ebuild90
-rw-r--r--www-apps/mythweb/mythweb-0.27.ebuild90
3 files changed, 0 insertions, 182 deletions
diff --git a/www-apps/mythweb/Manifest b/www-apps/mythweb/Manifest
index f88a1b3f7f75..fb066c9c4d81 100644
--- a/www-apps/mythweb/Manifest
+++ b/www-apps/mythweb/Manifest
@@ -1,3 +1 @@
-DIST mythplugins-0.26.0.tar.bz2 36673620 SHA256 4e7f0493f37792c084c1b4d0b5863b4201ebce6d62ab7c6cc31ca74087d83c62 SHA512 51c10f46186e14e69c5626f2ae0955692c71aa7459fd018efaab1b99809cad533a84754d53455017102ff6f94cc9905dc303248a29d4095ba8f4f685bb022f49 WHIRLPOOL a2b995f2a94a2eb22fa0740dd840a2fe2d9d4b808af1dc43e9d83c626d93ed95134d64db2049e4b79379838ae16b1de6547b56277531e2752e6779b3cddbf25a
DIST mythweb-0.27.5.tar.gz 1686597 SHA256 5dc3fd9e60f59dea4264fb064b40d73f2534c99d0399da6223a42d2f563e9d13 SHA512 effa5f9cab6b40423a819f0307aecd1faa397da7d859503162b6229e5da2d4cd0d95d793326768335518cd397fa58ba71ad98c14247feda10e7930f7e023f1af WHIRLPOOL 8721398611db0572f475f5642c397a5d3f0fbe352f0f3ea23dc21cc0ea94e0e6876a713cf0f99331c6fc1f585a62525dc64510737a85667c0e2a14b6f1c6bb10
-DIST mythweb-0.27.tar.gz 1686502 SHA256 7e54d6b388e2e8f3e50515c3fe46113f4217e3989242459a0fa73c928dcca494 SHA512 d166cd764730d844e844b5ba780b5635be6d2329d2051a382ab79579334e51fbfa0e73683e30c312d7618e84c7e63f868d32d5449d0804ff01dc0a592a60d9d1 WHIRLPOOL a2ad85234c2e9e2e6f370355becfca173a672afcb5c7d919fb046ab1a5e735683b96e3b6d36a2c83986116c568f878728988e78a1f27bd1861cd400a999b186a
diff --git a/www-apps/mythweb/mythweb-0.26.0.ebuild b/www-apps/mythweb/mythweb-0.26.0.ebuild
deleted file mode 100644
index f16b5a30b482..000000000000
--- a/www-apps/mythweb/mythweb-0.26.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils webapp
-
-#BACKPORTS="4f6ac2a60b"
-# Release version
-MY_PV="${PV%_p*}"
-MY_P="mythplugins-${MY_PV}"
-
-DESCRIPTION="PHP scripts intended to manage MythTV from a web browser"
-HOMEPAGE="http://www.mythtv.org"
-LICENSE="GPL-2"
-SRC_URI="ftp://ftp.osuosl.org/pub/mythtv/${MY_P}.tar.bz2
- ${BACKPORTS:+https://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
-IUSE=""
-KEYWORDS="~amd64 ~ppc ~x86"
-
-RDEPEND="dev-lang/php[json,mysql,session,posix]
- virtual/httpd-php
- dev-perl/DBI
- dev-perl/DBD-mysql
- dev-perl/HTTP-Date
- dev-perl/Net-UPnP"
-
-DEPEND="${RDEPEND}"
-
-need_httpd_cgi
-
-S="${WORKDIR}/${MY_P}/${PN}"
-
-src_prepare() {
- cd "${S}"/../
-
- [[ -n ${BACKPORTS} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/../patches" \
- epatch
-
- epatch_user
-}
-
-src_configure() {
- :
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- webapp_src_preinst
-
- # Install docs
- cd "${S}"
- dodoc README INSTALL
-
- # Install htdocs files
- insinto "${MY_HTDOCSDIR}"
- doins mythweb.php
- doins -r classes
- doins -r configuration
- doins -r data
- doins -r includes
- doins -r js
- doins -r modules
- doins -r skins
- doins -r tests
- exeinto "${MY_HTDOCSDIR}"
- doexe mythweb.pl
-
- # Install our server config files
- webapp_server_configfile apache mythweb.conf.apache mythweb.conf
- webapp_server_configfile lighttpd mythweb.conf.lighttpd mythweb.conf
- webapp_server_configfile nginx "${FILESDIR}"/mythweb.conf.nginx \
- mythweb.include
-
- # Data needs to be writable and modifiable by the web server
- webapp_serverowned -R "${MY_HTDOCSDIR}"/data
-
- # Message to display after install
- webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
-
- # Script to set the correct defaults on install
- webapp_hook_script "${FILESDIR}"/reconfig
-
- webapp_src_install
-}
diff --git a/www-apps/mythweb/mythweb-0.27.ebuild b/www-apps/mythweb/mythweb-0.27.ebuild
deleted file mode 100644
index affada03c0f0..000000000000
--- a/www-apps/mythweb/mythweb-0.27.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils webapp
-
-#BACKPORTS="4f6ac2a60b"
-# Release version
-MY_PV="${PV%_p*}"
-MY_P="mythweb-${MY_PV}"
-
-DESCRIPTION="PHP scripts intended to manage MythTV from a web browser"
-HOMEPAGE="http://www.mythtv.org"
-LICENSE="GPL-2"
-SRC_URI="https://github.com/MythTV/mythweb/archive/v${MY_PV}.tar.gz -> mythweb-${MY_PV}.tar.gz
- ${BACKPORTS:+https://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
-IUSE=""
-KEYWORDS="~amd64 ~ppc ~x86"
-
-RDEPEND="dev-lang/php[json,mysql,session,posix]
- virtual/httpd-php
- dev-perl/DBI
- dev-perl/DBD-mysql
- dev-perl/HTTP-Date
- dev-perl/Net-UPnP"
-
-DEPEND="${RDEPEND}"
-
-need_httpd_cgi
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- cd "${S}"/../
-
- [[ -n ${BACKPORTS} ]] && \
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/../patches" \
- epatch
-
- epatch_user
-}
-
-src_configure() {
- :
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- webapp_src_preinst
-
- # Install docs
- cd "${S}"
- dodoc README INSTALL
-
- # Install htdocs files
- insinto "${MY_HTDOCSDIR}"
- doins mythweb.php
- doins -r classes
- doins -r configuration
- doins -r data
- doins -r includes
- doins -r js
- doins -r modules
- doins -r skins
- doins -r tests
- exeinto "${MY_HTDOCSDIR}"
- doexe mythweb.pl
-
- # Install our server config files
- webapp_server_configfile apache mythweb.conf.apache mythweb.conf
- webapp_server_configfile lighttpd mythweb.conf.lighttpd mythweb.conf
- webapp_server_configfile nginx "${FILESDIR}"/mythweb.conf.nginx \
- mythweb.include
-
- # Data needs to be writable and modifiable by the web server
- webapp_serverowned -R "${MY_HTDOCSDIR}"/data
-
- # Message to display after install
- webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
-
- # Script to set the correct defaults on install
- webapp_hook_script "${FILESDIR}"/reconfig
-
- webapp_src_install
-}