summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/nanoblogger/nanoblogger-3.2.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/nanoblogger/nanoblogger-3.2.3.ebuild')
-rw-r--r--www-apps/nanoblogger/nanoblogger-3.2.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/www-apps/nanoblogger/nanoblogger-3.2.3.ebuild b/www-apps/nanoblogger/nanoblogger-3.2.3.ebuild
new file mode 100644
index 000000000000..285ef7abb81f
--- /dev/null
+++ b/www-apps/nanoblogger/nanoblogger-3.2.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit bash-completion-r1
+
+DESCRIPTION="Small and simple weblog engine written in Bash for the command-line"
+HOMEPAGE="http://nanoblogger.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ia64 ~mips ppc x86"
+IUSE=""
+
+RDEPEND="app-shells/bash"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's|^\(NB_BASE_DIR=\).*$|\1"/usr/share/nanoblogger"|' \
+ -e 's|"$NB_BASE_DIR/\(nb\.conf\)"|"/etc/\1"|g' \
+ -e "s|\$NB_BASE_DIR.*\(nano.*html\)|/usr/share/doc/${PF}/html/\1|" \
+ nb || die "sed nb failed"
+}
+
+src_install() {
+ dobin nb
+ insinto /usr/share/nanoblogger
+ doins -r default moods plugins
+ insinto /etc
+ doins nb.conf
+ dodoc ChangeLog
+ dohtml docs/nanoblogger.html
+ dobashcomp "${FILESDIR}"/nb.bashcomp || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Documentation for getting started with nanoblogger may be found at"
+ elog "/usr/share/doc/${PF}/html/nanoblogger.html or by running 'nb --manual;."
+ elog
+ elog "To create and configure a new weblog, run the following as your user:"
+ elog " nb -b /some/dir -a"
+ elog "where /some/dir is a directory that DOES NOT exist."
+ elog
+ elog "To prevent having to specify your blog directory every time you use"
+ elog "nanoblogger (with the -b switch), you can set a default value in your"
+ elog "~/.nb.conf. For example:"
+ elog ' BLOG_DIR="$HOME/public_html/blog"'
+ elog
+ elog "If you are upgrading nanoblogger from a previous version, follow"
+ elog "these directions (as stated in the manual):"
+ elog " 1. create a new weblog directory using nanoblogger (skip configuration):"
+ elog " nb [-b blog_dir] -a"
+ elog " 2. copy old data directry to new weblog:"
+ elog " cp -r [old_blog_dir]/data [newblog_dir]"
+ elog " 3. edit new blog.conf to your liking and rebuild weblog:"
+ elog " nb [-b blog_dir] --configure -u all"
+ elog
+}