summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-11 21:13:53 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-11 21:14:12 +0200
commit1bdb94a1dda6a002deab53c19aeef41d4ff3b552 (patch)
treecfa4f7d1b5ab349b9680d04455e7f406c3d64b13 /www-apps/nanoc
parentdev-ruby/mustache: avoid minitest plugins (diff)
downloadgentoo-1bdb94a1dda6a002deab53c19aeef41d4ff3b552.tar.gz
gentoo-1bdb94a1dda6a002deab53c19aeef41d4ff3b552.tar.bz2
gentoo-1bdb94a1dda6a002deab53c19aeef41d4ff3b552.zip
www-apps/nanoc: enable ruby32
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-apps/nanoc')
-rw-r--r--www-apps/nanoc/nanoc-4.12.16.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/www-apps/nanoc/nanoc-4.12.16.ebuild b/www-apps/nanoc/nanoc-4.12.16.ebuild
index 826e15fcb9cf..96152932c2bc 100644
--- a/www-apps/nanoc/nanoc-4.12.16.ebuild
+++ b/www-apps/nanoc/nanoc-4.12.16.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby30 ruby31"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
@@ -81,9 +81,9 @@ all_ruby_prepare() {
# about the local network environment.
rm -f test/checking/checks/test_{css,html}.rb spec/nanoc/cli/commands/view_spec.rb || die
- # Avoid tests for unpackaged dependencies
+ # Avoid tests for unpackaged or obsolete dependencies
rm spec/nanoc/filters/less_spec.rb \
- test/filters/test_{markaby,rainpress}.rb || die
+ test/filters/test_{erubis,markaby,rainpress}.rb || die
# Avoid tests that are specific to haml 6.x which is currently not packaged
sed -i -e '/test_filter_\(with_proper_indentation\|error\)/askip "haml 6"' test/filters/test_haml.rb || die
@@ -93,6 +93,9 @@ all_ruby_prepare() {
-i spec/nanoc/data_sources/filesystem_spec.rb || die
sed -e '/def test_default_encoding/,/^ end/ s:^:#:' \
-i test/orig_cli/commands/test_create_site.rb || die
+
+ # Fix deprecated minitest constant
+ sed -i -e 's/MiniTest/Minitest/' test/rule_dsl/test_rules_collection.rb || die
}
each_ruby_test() {