summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/nanoc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/nanoc')
-rw-r--r--www-apps/nanoc/Manifest2
-rw-r--r--www-apps/nanoc/metadata.xml6
-rw-r--r--www-apps/nanoc/nanoc-3.7.5-r1.ebuild58
-rw-r--r--www-apps/nanoc/nanoc-3.7.5.ebuild57
-rw-r--r--www-apps/nanoc/nanoc-3.8.0.ebuild58
5 files changed, 181 insertions, 0 deletions
diff --git a/www-apps/nanoc/Manifest b/www-apps/nanoc/Manifest
new file mode 100644
index 000000000000..9a72b82d4eda
--- /dev/null
+++ b/www-apps/nanoc/Manifest
@@ -0,0 +1,2 @@
+DIST nanoc-3.7.5.gem 185856 SHA256 504309339c3e7711e6d75741b8bfa1ac1c6bcbd4a6accfc7beafbd5a45812602 SHA512 3cf6562e06d20afbc378e1d83a0545b8b6309c3c273a05538b62dd75ddbb80f4cbfc90b9225981562e561ab59a9e4e7810515da60ed12c797af4086b2531a1c7 WHIRLPOOL c1327033847a9a773e8d19795c36971ecf84d37386a7a33556b82a1563da321096b7a6596f982fa3159b6443a2c94c1ecf3ae14dd3b7f12000bb46d807ba0df4
+DIST nanoc-3.8.0.gem 189440 SHA256 382397d761ea1a97537eaee995e37ba416f7f7f093090cc812071a9eb28cea1e SHA512 ed39b6e799ea16fe19539181c0de2054af428b0ecdec5cfd592948aa14f3f0e7233a6039e57d68d9046824f55b7fc00d4f2621c4bd4b77d243e40c5c8750e93e WHIRLPOOL 33b92d6da24974c1d525d8da2433d62863ff97423ad8079c3937ac1c5c98fa310a05b179afa390d1fe3758a2e423951c880210508fdcbfc9c601e67fcbb841c5
diff --git a/www-apps/nanoc/metadata.xml b/www-apps/nanoc/metadata.xml
new file mode 100644
index 000000000000..3c43de11d5ec
--- /dev/null
+++ b/www-apps/nanoc/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>graaff@gentoo.org</email></maintainer>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/www-apps/nanoc/nanoc-3.7.5-r1.ebuild b/www-apps/nanoc/nanoc-3.7.5-r1.ebuild
new file mode 100644
index 000000000000..542351d6ce1c
--- /dev/null
+++ b/www-apps/nanoc/nanoc-3.7.5-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog NEWS.md README.md"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_TASK_TEST="test:all"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="http://nanoc.ws/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types
+ dev-ruby/rack
+)
+ >=dev-ruby/cri-2.3:0"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ =dev-ruby/rdoc-4*
+ dev-ruby/systemu
+ dev-ruby/vcr
+ dev-ruby/yard
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ use doc || use test || (rm tasks/doc.rake || die)
+ use test || (rm tasks/test.rake || die)
+
+ # Avoid dependency on coveralls.
+ sed -i -e '/coverall/I s:^:#:' test/helper.rb || die
+
+ # Avoid non-optional tests for w3c_validators which we don't have
+ # packaged and which require network access.
+ rm test/extra/checking/checks/test_{css,html}.rb || die
+
+ # Skip a test that produces slightly different javascript.
+ sed -i -e '/test_filter_with_options/,/^ end/ s:^:#:' test/filters/test_uglify_js.rb || die
+}
diff --git a/www-apps/nanoc/nanoc-3.7.5.ebuild b/www-apps/nanoc/nanoc-3.7.5.ebuild
new file mode 100644
index 000000000000..6107985841ac
--- /dev/null
+++ b/www-apps/nanoc/nanoc-3.7.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog NEWS.md README.md"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_TASK_TEST="test:all"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="http://nanoc.ws/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types
+ dev-ruby/rack
+)
+ >=dev-ruby/cri-2.3:0"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ =dev-ruby/rdoc-4*
+ dev-ruby/systemu
+ dev-ruby/yard
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ use doc || use test || (rm tasks/doc.rake || die)
+ use test || (rm tasks/test.rake || die)
+
+ # Avoid dependency on coveralls.
+ sed -i -e '/coverall/I s:^:#:' test/helper.rb || die
+
+ # Avoid non-optional tests for w3c_validators which we don't have
+ # packaged and which require network access.
+ rm test/extra/checking/checks/test_{css,html}.rb || die
+
+ # Skip a test that produces slightly different javascript.
+ sed -i -e '/test_filter_with_options/,/^ end/ s:^:#:' test/filters/test_uglify_js.rb || die
+}
diff --git a/www-apps/nanoc/nanoc-3.8.0.ebuild b/www-apps/nanoc/nanoc-3.8.0.ebuild
new file mode 100644
index 000000000000..cf43c1ae857a
--- /dev/null
+++ b/www-apps/nanoc/nanoc-3.8.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog NEWS.md README.md"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_TASK_TEST="test:all"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="http://nanoc.ws/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types:*
+ dev-ruby/rack:*
+)
+ >=dev-ruby/cri-2.3:0"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ =dev-ruby/rdoc-4*
+ dev-ruby/systemu
+ dev-ruby/vcr
+ dev-ruby/yard
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ use doc || use test || (rm tasks/doc.rake || die)
+ use test || (rm tasks/test.rake || die)
+
+ # Avoid dependency on coveralls.
+ sed -i -e '/coverall/I s:^:#:' test/helper.rb || die
+
+ # Avoid non-optional tests for w3c_validators which we don't have
+ # packaged and which require network access.
+ rm test/extra/checking/checks/test_{css,html}.rb || die
+
+ # Skip a test that produces slightly different javascript.
+ sed -i -e '/test_filter_with_options/,/^ end/ s:^:#:' test/filters/test_uglify_js.rb || die
+}