summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-09-25 12:15:49 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-09-25 12:35:38 -0500
commit4e82a7f6b4a96ca9335898b81f3c54d1f69cd42e (patch)
tree43485980f07debaeef7f634cd35aadc5f4cc443f /www-apps/netbox
parentdev-python/jira: USE=filemagic → magic, to match global (diff)
downloadgentoo-4e82a7f6b4a96ca9335898b81f3c54d1f69cd42e.tar.gz
gentoo-4e82a7f6b4a96ca9335898b81f3c54d1f69cd42e.tar.bz2
gentoo-4e82a7f6b4a96ca9335898b81f3c54d1f69cd42e.zip
www-apps/netbox: 2.6.4 bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'www-apps/netbox')
-rw-r--r--www-apps/netbox/Manifest1
-rw-r--r--www-apps/netbox/files/netbox-2.6.4-no-pip.patch21
-rw-r--r--www-apps/netbox/netbox-2.6.4.ebuild124
3 files changed, 146 insertions, 0 deletions
diff --git a/www-apps/netbox/Manifest b/www-apps/netbox/Manifest
index 51a181dd107c..5e9c37e7f7f0 100644
--- a/www-apps/netbox/Manifest
+++ b/www-apps/netbox/Manifest
@@ -1,3 +1,4 @@
DIST netbox-2.5.11.tar.gz 2364831 BLAKE2B e5117b2d4c3f33b231715a8b192e7954dc0611fcb270937c5c8abda3abc9f9925bd7db2c7306847428b5a24014d0c0b07ee404294b389a708d0dc7963c250691 SHA512 dfd19af01bf096ee7d8790981853d7e94d8926a4f0eeb00a061f805d56486670c058752b9a9fb23882b0b8d33e4a2d62f50a35b56c28eb2782be47e6f4b13b7d
DIST netbox-2.5.12.tar.gz 2364874 BLAKE2B efe1360fd7c1105e5c6010ee22a882fb4fc796ff0f907974984dba35a0ab6da7724fd6042b102cebe3e3e291c3a1c65c347a5967edbaf443ece6fe61648a93be SHA512 e105a351f1150139c5bce36527ea650f95504ccc1c7b6a82c41396d69bc8671758cc3b33789c95c81785c5ff54d34c7310cd3e03e65bd006606e85021dcd1795
DIST netbox-2.6.1.tar.gz 2393902 BLAKE2B 027115458cbb873cb7aa7660a6cd1df46a7768dc05c9280f94c23368336752034b8ede591ed4337f6b65ade1db7fac740533c3c2d932043172cf296ddd2e3f8a SHA512 8cfe4384ed4ad682ff5268e83d72716230683e86e858c857fd694838227a8b3eddfe02c1fc39b00cb36b33519d8cbb942dd4008544943e8b8f7f2d5904c10e5a
+DIST netbox-2.6.4.tar.gz 2408970 BLAKE2B 47fa3473e893e8443aace8b587df0065a3024a34f9509644deddce7c53e5ac8b3832df55604f3328d699f8f703ae15ad5b52312e1af8fcccabb7cd06377c8a09 SHA512 b137ec7f2d33bb7b48bcb38719ac9ea8cc31d7d38e33cedfb3279b8be2078c9a48ede10db1e4b4cab4a08c77e010060936e445cb6a1d2e6247bcc8d935cc9c3a
diff --git a/www-apps/netbox/files/netbox-2.6.4-no-pip.patch b/www-apps/netbox/files/netbox-2.6.4-no-pip.patch
new file mode 100644
index 000000000000..ba281aaea5d1
--- /dev/null
+++ b/www-apps/netbox/files/netbox-2.6.4-no-pip.patch
@@ -0,0 +1,21 @@
+diff --git a/upgrade.sh b/upgrade.sh
+index 793e72cd..8490d713 100755
+--- a/upgrade.sh
++++ b/upgrade.sh
+@@ -10,16 +10,6 @@ cd "$(dirname "$0")"
+ PYTHON="python3"
+ PIP="pip3"
+
+-# Uninstall any Python packages which are no longer needed
+-COMMAND="${PIP} uninstall -r old_requirements.txt -y"
+-echo "Removing old Python packages ($COMMAND)..."
+-eval $COMMAND
+-
+-# Install any new Python packages
+-COMMAND="${PIP} install -r requirements.txt --upgrade"
+-echo "Updating required Python packages ($COMMAND)..."
+-eval $COMMAND
+-
+ # Apply any database migrations
+ COMMAND="${PYTHON} netbox/manage.py migrate"
+ echo "Applying database migrations ($COMMAND)..."
diff --git a/www-apps/netbox/netbox-2.6.4.ebuild b/www-apps/netbox/netbox-2.6.4.ebuild
new file mode 100644
index 000000000000..24d3873dc160
--- /dev/null
+++ b/www-apps/netbox/netbox-2.6.4.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 )
+inherit python-single-r1 user readme.gentoo-r1
+
+DESCRIPTION="IP address and data center infrastructure management tool"
+HOMEPAGE="https://github.com/netbox-community/netbox"
+SRC_URI="https://github.com/netbox-community/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ldap webhooks"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/django-cacheops-4.1[${PYTHON_USEDEP}]
+ >=dev-python/django-cors-headers-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/django-debug-toolbar-2.0[${PYTHON_USEDEP}]
+ >=dev-python/django-filter-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/django-mptt-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/django-prometheus-1.0.15[${PYTHON_USEDEP}]
+ >=dev-python/django-tables2-2.0.6[${PYTHON_USEDEP}]
+ >=dev-python/django-taggit-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/django-taggit-serializer-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/django-timezone-field-3.0[${PYTHON_USEDEP}]
+ >=dev-python/djangorestframework-3.9.4[${PYTHON_USEDEP}]
+ >=dev-python/drf-yasg-1.16.0[${PYTHON_USEDEP},validation]
+ >=dev-python/graphviz-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.6.11[${PYTHON_USEDEP}]
+ <dev-python/markdown-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.19[${PYTHON_USEDEP}]
+ >=dev-python/pillow-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.3[${PYTHON_USEDEP}]
+ >=dev-python/py-gfm-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.8.2[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ ldap? ( >=dev-python/django-auth-ldap-1.7[${PYTHON_USEDEP}] )
+ webhooks? ( >=dev-python/django-rq-2.1.0[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no-pip.patch
+ )
+
+DISABLE_AUTOFORMATTING=YES
+DOC_CONTENTS="
+netbox is installed on your system. However, there are some manual steps
+you need to complete from the installation guide [1].
+
+On Gentoo, the configuration files you need to edit are located in
+/etc/netbox, not /opt/netbox as shown in the installation guide.
+
+If this is a new installation, please follow the installation guide
+other than this difference. Also, if you need ldap or webhooks, set the
+appropriate use flags when you emerge netbox to install the
+dependencies.
+
+Once that is done, you should be able to add the netbox service to the
+default runlevel and start it.
+
+If you have webhooks turned on, you should also add the netbox-rqworker
+service to the default runlevel and start it.
+
+If this is an upgrade, follow these instructions:
+
+Stop the netbox service. If the netbox-rqworker service is running,
+stop it as well.
+
+Next, run the upgrade script as described in the upgrading guide[2].
+
+Next, check for new configuration options and set them as appropriate
+for your system.
+
+Next, start the netbox service.
+
+Finally, if you are using webhooks, start the netbox-rqworker service.
+
+[1] https://netbox.readthedocs.io/en/stable/installation/
+[2] https://netbox.readthedocs.io/en/stable/installation/upgrading/
+"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_install() {
+ dodir /opt
+ cp -a ../${P} "${ED}"/opt
+ dosym ${P} /opt/netbox
+dosym ../../etc/netbox/gunicorn_config.py /opt/netbox/gunicorn_config.py
+ dosym ../../../../etc/netbox/configuration.py \
+ /opt/netbox/netbox/netbox/configuration.py
+ dodir /etc/netbox
+ insinto /etc/netbox
+ newins netbox/netbox/configuration.example.py configuration.py
+ doins "${FILESDIR}"/gunicorn_config.py
+ fowners -R netbox:netbox /etc/netbox /opt/${P}
+ fowners -h netbox:netbox /opt/netbox
+ fperms o= /etc/netbox/configuration.py /etc/netbox/gunicorn_config.py
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use webhooks &&
+ newinitd "${FILESDIR}"/${PN}-rqworker.initd ${PN}-rqworker
+ keepdir /var/log/netbox
+ fowners -R netbox:netbox /var/log/netbox
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ local r
+ for r in $REPLACING_VERSIONS; do
+ if [[ $r = "2.5.10" ]]; then
+ ewarn "The home directory of the netbox user is now /var/lib/netbox"
+ ewarn "Please adjust your system."
+ fi
+ done
+}