summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2018-04-05 09:50:30 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-04-05 10:34:00 +0200
commit9b9c50949dcffcd5f08a5e4e48672d68bca3a32a (patch)
tree2a72880a2a683dc333e0e2b024804a8772b4ee58 /www-apps/nextcloud/nextcloud-13.0.1.ebuild
parentwww-apps/nextcloud: drop old versions (diff)
downloadgentoo-9b9c50949dcffcd5f08a5e4e48672d68bca3a32a.tar.gz
gentoo-9b9c50949dcffcd5f08a5e4e48672d68bca3a32a.tar.bz2
gentoo-9b9c50949dcffcd5f08a5e4e48672d68bca3a32a.zip
www-apps/nextcloud: 12.0.6 and 13.0.1 bumps
Closes: https://bugs.gentoo.org/651284 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'www-apps/nextcloud/nextcloud-13.0.1.ebuild')
-rw-r--r--www-apps/nextcloud/nextcloud-13.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/nextcloud/nextcloud-13.0.1.ebuild b/www-apps/nextcloud/nextcloud-13.0.1.ebuild
new file mode 100644
index 000000000000..f7e6255e6454
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-13.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="http://nextcloud.com"
+SRC_URI="http://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+curl mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash,json,mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,xmlreader,xmlwriter,zip]
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_src_install
+}