summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-10-03 10:39:46 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-10-03 11:56:38 +0200
commit31a212d2d7f83464f3156d3ceab7cdfa338004a7 (patch)
treeb14d5aca73c0943dc7b02d55ecb9967bcc730bbf /www-apps/nextcloud
parentnet-misc/nextcloud-client: 3.3.5 bump (diff)
downloadgentoo-31a212d2d7f83464f3156d3ceab7cdfa338004a7.tar.gz
gentoo-31a212d2d7f83464f3156d3ceab7cdfa338004a7.tar.bz2
gentoo-31a212d2d7f83464f3156d3ceab7cdfa338004a7.zip
www-apps/nextcloud: 22.2.0, 21.0.5, 20.0.13 bumps
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/nextcloud')
-rw-r--r--www-apps/nextcloud/Manifest3
-rw-r--r--www-apps/nextcloud/nextcloud-20.0.13.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-21.0.5.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-22.2.0.ebuild43
4 files changed, 132 insertions, 0 deletions
diff --git a/www-apps/nextcloud/Manifest b/www-apps/nextcloud/Manifest
index 4c333a9f535d..6bf62b3eb8fa 100644
--- a/www-apps/nextcloud/Manifest
+++ b/www-apps/nextcloud/Manifest
@@ -1,3 +1,6 @@
DIST nextcloud-20.0.12.tar.bz2 123184555 BLAKE2B cf1493215a9efc5a6a7e90b3ed92510b629ff3109dc8e7b4a802bc45190604ee42700350c6f76b78823e95c5dee5bcaf3a95d12ed14b64365eee882ac3b8b622 SHA512 423c09256c31bf9530f97eb0961471cd87c23a0d46de9d4eb9a63270a67ea7c861ca77c83fa203426b5f3cae717202dbd44ccdd6b432ae06570c0a0cf6d4dc5e
+DIST nextcloud-20.0.13.tar.bz2 110837657 BLAKE2B b29a0b1db7dba682fee13a38e95502b7235c926a323a34f6c8e38d19876f0c3484d922a9602c0211320d8d82b0da2063612812846809c14c38853bcc6bf450f3 SHA512 a31182e7efcf151bb46f71147025aff6a00f8c7dbd545338e8005c40c2b82b21a75ea73a2119db3029e7dd85b9b018e417525b3ab59a3353dd73eafcf87122d0
DIST nextcloud-21.0.4.tar.bz2 140200496 BLAKE2B 9dd54a10dda30fdd1107266c8acc7f0161596107c04546336f29ac523275c93be8fd1877558c1b7e469769f5e30f3eb2179896c8bb26db4c20bf6a44f8bc3df7 SHA512 7fef1aa4bc4b9c158a3c50bdff87054b97cfeed8d066076676f00189380c115d318a657492dc2a0f138b85f15fd7dc807c0137775b76f37dbc7b052514614390
+DIST nextcloud-21.0.5.tar.bz2 127542660 BLAKE2B b6c2bc642705ba5572a74a1f473e09a7be0ad6c4937b1a15d3b29bdad652872c373b9b6ab126c1ea90f32dced3fbb34505c82a7fc9d6913e407c6e43b97fe55b SHA512 ef8796cb17e6143dc1c9ccdea56105d0d7e2138eddae228724074b6360f99d0416a3682be047955b9a84dd6a961cdbb15ccff67ee6656a896699bbfa640d715d
DIST nextcloud-22.1.1.tar.bz2 145195483 BLAKE2B 6572c3b90199b4ca1118f35b412e580c824eb688fca92a38ba578a1d9fe9630f137d5c0a9b3ab3428849b479f09e3d5b90cfc1477c59028755e75070591807e3 SHA512 0b418d7d0e0e825ec9259334e377449a8dcd183dc907b094361c70b51b00732353996fdbf12f17c06cfa6bb918221cac56ee3051df0308ff453bb2d727e9c0ad
+DIST nextcloud-22.2.0.tar.bz2 131241307 BLAKE2B b23526c0a12817b16fa7733b34143bdd4a581b829a7934e6d6865b028ccb46cb3e08b6a077325feea1234d966b36a3017ee6d9443851d30481955654840c29ca SHA512 ecf308fdd46f43e4507d90eae90f4fece4410ac546929cda8ce3f0c48db7fc644a37558c4d1aeef8943cda4c0474d6afa5e151af5c5b9c6f17b4ae05f5e0fc26
diff --git a/www-apps/nextcloud/nextcloud-20.0.13.ebuild b/www-apps/nextcloud/nextcloud-20.0.13.ebuild
new file mode 100644
index 000000000000..2aebb2320d5d
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-20.0.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="<dev-lang/php-8[curl?,filter,gd,hash(+),intl,json,mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-21.0.5.ebuild b/www-apps/nextcloud/nextcloud-21.0.5.ebuild
new file mode 100644
index 000000000000..ab3ba8e01bc4
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-21.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-22.2.0.ebuild b/www-apps/nextcloud/nextcloud-22.2.0.ebuild
new file mode 100644
index 000000000000..ab3ba8e01bc4
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-22.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}