summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-15 21:50:55 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-15 21:51:14 -0500
commit6194e7533aed11c5597ed429134d826bf60fb267 (patch)
tree721cea8efeb5bd0b5c5fa590650860aa452d229e /www-apps/novnc/novnc-1.0.0.ebuild
parentdev-python/pillow: amd64 stable wrt bug #660548 (diff)
downloadgentoo-6194e7533aed11c5597ed429134d826bf60fb267.tar.gz
gentoo-6194e7533aed11c5597ed429134d826bf60fb267.tar.bz2
gentoo-6194e7533aed11c5597ed429134d826bf60fb267.zip
www-apps/novnc: 1.0.0 bup
Closes: https://bugs.gentoo.org/661130 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-apps/novnc/novnc-1.0.0.ebuild')
-rw-r--r--www-apps/novnc/novnc-1.0.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-apps/novnc/novnc-1.0.0.ebuild b/www-apps/novnc/novnc-1.0.0.ebuild
new file mode 100644
index 000000000000..8ef65ad0e359
--- /dev/null
+++ b/www-apps/novnc/novnc-1.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="https://kanaka.github.com/noVNC/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kanaka/noVNC.git"
+else
+ SRC_URI="https://github.com/kanaka/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/noVNC-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/websockify[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+python_compile() {
+ echo
+}
+
+src_install() {
+ exeinto /usr/share/novnc/utils
+ for f in utils/*; do
+ [[ ! f = utils/README.md ]] && doexe $f
+ done
+
+ dodoc README.md LICENSE.txt
+
+ insinto /usr/share/novnc
+ doins -r vnc.html vnc_lite.html app/ core/ vendor/
+ dosym /usr/share/novnc/vnc_lite.html /usr/share/novnc/vnc_auto.html # for compat
+}