summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/phpwebsite/phpwebsite-1.7.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/phpwebsite/phpwebsite-1.7.2.ebuild')
-rw-r--r--www-apps/phpwebsite/phpwebsite-1.7.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-apps/phpwebsite/phpwebsite-1.7.2.ebuild b/www-apps/phpwebsite/phpwebsite-1.7.2.ebuild
new file mode 100644
index 000000000000..3af467c7165d
--- /dev/null
+++ b/www-apps/phpwebsite/phpwebsite-1.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit webapp
+
+MY_PV=${PV//./_}
+DESCRIPTION="phpWebSite Content Management System"
+HOMEPAGE="http://phpwebsite.appstate.edu"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ppc ~ppc64 x86"
+IUSE="+mysql postgres"
+REQUIRED_USE="|| ( mysql postgres )"
+
+S="${WORKDIR}"/${PN}_${MY_PV}
+
+RDEPEND="virtual/httpd-php
+ dev-lang/php[gd,mysql?,postgres?]"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README docs/*
+
+ cp -r * "${D}/${MY_HTDOCSDIR}"
+
+ # Files that need to be owned by webserver
+ webapp_serverowned ${MY_HTDOCSDIR}/config
+ webapp_serverowned ${MY_HTDOCSDIR}/config/core
+ webapp_serverowned ${MY_HTDOCSDIR}/files
+ webapp_serverowned ${MY_HTDOCSDIR}/images
+ webapp_serverowned ${MY_HTDOCSDIR}/mod
+ webapp_serverowned ${MY_HTDOCSDIR}/logs
+ webapp_serverowned ${MY_HTDOCSDIR}/templates
+ webapp_serverowned ${MY_HTDOCSDIR}/javascript
+
+# webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}