summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-07-01 22:01:22 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-07-01 22:01:35 +0200
commitf2757ac2b191f5cce7b0e1530399f8962db8783f (patch)
treed43496c56ea3c0628757a8fcc652f281323188d9 /www-apps/piwigo/piwigo-12.3.0.ebuild
parentsys-devel/rust-std: drop 1.58.1 (diff)
downloadgentoo-f2757ac2b191f5cce7b0e1530399f8962db8783f.tar.gz
gentoo-f2757ac2b191f5cce7b0e1530399f8962db8783f.tar.bz2
gentoo-f2757ac2b191f5cce7b0e1530399f8962db8783f.zip
www-apps/piwigo: add 12.3.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/piwigo/piwigo-12.3.0.ebuild')
-rw-r--r--www-apps/piwigo/piwigo-12.3.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/www-apps/piwigo/piwigo-12.3.0.ebuild b/www-apps/piwigo/piwigo-12.3.0.ebuild
new file mode 100644
index 000000000000..5d7d1f3343b3
--- /dev/null
+++ b/www-apps/piwigo/piwigo-12.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json(+),mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}