summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-03-20 16:55:04 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-03-20 17:17:42 +0100
commita10a49c90e9411c2120fa3af5a2e6d97c396bb2c (patch)
tree7f3b9a4a460155907b1df7e61d29166c4dfe0d60 /www-apps/piwigo
parentwww-apps/piwigo: drop old (diff)
downloadgentoo-a10a49c90e9411c2120fa3af5a2e6d97c396bb2c.tar.gz
gentoo-a10a49c90e9411c2120fa3af5a2e6d97c396bb2c.tar.bz2
gentoo-a10a49c90e9411c2120fa3af5a2e6d97c396bb2c.zip
www-apps/piwigo: 11.4.0 bump
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/piwigo')
-rw-r--r--www-apps/piwigo/Manifest1
-rw-r--r--www-apps/piwigo/piwigo-11.4.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/piwigo/Manifest b/www-apps/piwigo/Manifest
index a189d360662b..cb9254cf992a 100644
--- a/www-apps/piwigo/Manifest
+++ b/www-apps/piwigo/Manifest
@@ -1 +1,2 @@
DIST piwigo-11.3.0.zip 17695593 BLAKE2B cc77c6b041c19714bed3d3a767e8a1c69d623c711c47601d606000fbab16fbb51ea781c5a01e12e7ed40468bef769d323676a61711cc092f024c874ce67825c9 SHA512 5544e94801007a80ffe8951a1427ef75245c09aa41991679baed112068c2acf751543428842e98305db0a17b3938846ed40e3c5f7c301d1b155b8673557585c4
+DIST piwigo-11.4.0.zip 17728014 BLAKE2B 54888c89667970a86e2153d42e377165cb19f1dc6fa7b481b440a1e3c2803139202d8b22e78a5c15378e12f55999a10693a0b56f6a4b14a2153b3b00e39eaacc SHA512 7e8288d51d9b7dfacdb2534e7f36a6230799c3649f827ffc12b3c5b4420bf35de315373e2e6b27edb120c008c3ff5c7de359afcc29879454c82ce1c2016d2146
diff --git a/www-apps/piwigo/piwigo-11.4.0.ebuild b/www-apps/piwigo/piwigo-11.4.0.ebuild
new file mode 100644
index 000000000000..978f3b237a3f
--- /dev/null
+++ b/www-apps/piwigo/piwigo-11.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+DEPEND=""
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json,mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+S=${WORKDIR}/${PN}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}