summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2021-11-21 13:09:07 +0100
committerCédric Krier <cedk@gentoo.org>2021-11-21 18:49:46 +0100
commit5498bd160f1ab0cf37a124c726fead459db05c13 (patch)
tree186cf0c7dca03239c78e0b64f4ee54b7c4c1a88f /www-apps/roundup/roundup-2.1.0.ebuild
parentdev-util/diffuse: bump to 0.7.2 (diff)
downloadgentoo-5498bd160f1ab0cf37a124c726fead459db05c13.tar.gz
gentoo-5498bd160f1ab0cf37a124c726fead459db05c13.tar.bz2
gentoo-5498bd160f1ab0cf37a124c726fead459db05c13.zip
www-apps/roundup: version bumps
Closes: https://bugs.gentoo.org/820458 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Cédric Krier <cedk@gentoo.org>
Diffstat (limited to 'www-apps/roundup/roundup-2.1.0.ebuild')
-rw-r--r--www-apps/roundup/roundup-2.1.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apps/roundup/roundup-2.1.0.ebuild b/www-apps/roundup/roundup-2.1.0.ebuild
new file mode 100644
index 000000000000..efc8e54efbc0
--- /dev/null
+++ b/www-apps/roundup/roundup-2.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+MY_P=${P/_/}
+
+DESCRIPTION="Issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="http://roundup.sourceforge.net https://pypi.org/project/roundup/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+tz sqlite mysql postgres xapian whoosh ssl jinja pyjwt markdown"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ tz? ( dev-python/pytz[$PYTHON_USEDEP] )
+ sqlite? ( $(python_gen_impl_dep sqlite) )
+ mysql? ( dev-python/mysqlclient[$PYTHON_USEDEP] )
+ postgres? ( >=dev-python/psycopg-2.8[$PYTHON_USEDEP] )
+ xapian? ( >=dev-libs/xapian-bindings-1.0.0[python,$PYTHON_USEDEP] )
+ whoosh? ( >=dev-python/whoosh-2.5.7[$PYTHON_USEDEP] )
+ ssl? ( dev-python/pyopenssl[$PYTHON_USEDEP] )
+ jinja? ( dev-python/jinja[$PYTHON_USEDEP] )
+ pyjwt? ( dev-python/pyjwt[$PYTHON_USEDEP] )
+ markdown? (
+ || (
+ dev-python/markdown[$PYTHON_USEDEP]
+ dev-python/markdown2[$PYTHON_USEDEP]
+ dev-python/mistune[$PYTHON_USEDEP]
+ )
+ )"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+}
+
+pkg_postinst() {
+ ewarn "See installation.txt for initialisation instructions."
+ ewarn "See upgrading.txt for upgrading instructions."
+}