summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/roundup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/roundup')
-rw-r--r--www-apps/roundup/Manifest3
-rw-r--r--www-apps/roundup/metadata.xml8
-rw-r--r--www-apps/roundup/roundup-1.4.20.ebuild45
-rw-r--r--www-apps/roundup/roundup-1.4.21.ebuild39
-rw-r--r--www-apps/roundup/roundup-1.5.0.ebuild40
5 files changed, 135 insertions, 0 deletions
diff --git a/www-apps/roundup/Manifest b/www-apps/roundup/Manifest
new file mode 100644
index 000000000000..325991a156e5
--- /dev/null
+++ b/www-apps/roundup/Manifest
@@ -0,0 +1,3 @@
+DIST roundup-1.4.20.tar.gz 2127168 SHA256 a38a2f4bdf1076f2107de683f1d4e10450edaf94a1be9438198a5cb2241a13a2 SHA512 62a1ca744afb7e17a4e165d695e1623d73810a3d3e6c374a4b73d010fcc3e93756ca0bfb6dc4cf7937acd1156c4b938e881e2e9ffd9b0c8e4c4366b730cc43b1 WHIRLPOOL 6fb918d427f304081b666390eefbc3a330bfe9a93b6e89aef2905e2b27b2a68fe74691fbf95569095b4f504703f9cd68823c3c9761b25db5be9cfa6439a07dd5
+DIST roundup-1.4.21.tar.gz 2460371 SHA256 3cb940e7e9063f8c821952796eee3997a8fd944bf570025ccc9a02e19c9ab644 SHA512 1c978c5c6030659d6a9618c9c0a6fa9afc28f21e8eac88fd208dd64a37818da65ce3b5b69010f5846e539408f135636221180e7ee873e36333ae0a92f6029a5f WHIRLPOOL 1b60030e2ce5df692c9eb480cd5572af3927ee0bcfec00f17b83b2a59e21f893bc7660ccf2eebd26fc862db87260654234066baab4d07bec5144af02b28da1a3
+DIST roundup-1.5.0.tar.gz 2388893 SHA256 45ab9d3d92ff4ad7f1bb7ac561df43ca3c7e07129caab0dea810aa508f047be7 SHA512 b861f1fe63b702a4831773a291907818c853fa3593b05165019ea666a3ee2dd538845db8bcb5156cf2247caa4180f3ad44d1e08ed9279d95c131313934e39d70 WHIRLPOOL 2821cf7714cbd22694b0195419af75d90fb7b7bb3507bc706a3398bcae23500d63a82bb67eeb9482a7ae1296b5b3096fde2fee10d49282db176159d9009776d7
diff --git a/www-apps/roundup/metadata.xml b/www-apps/roundup/metadata.xml
new file mode 100644
index 000000000000..9e455a6b92ae
--- /dev/null
+++ b/www-apps/roundup/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <upstream>
+ <remote-id type="pypi">roundup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apps/roundup/roundup-1.4.20.ebuild b/www-apps/roundup/roundup-1.4.20.ebuild
new file mode 100644
index 000000000000..99299afc7f6d
--- /dev/null
+++ b/www-apps/roundup/roundup-1.4.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="http://roundup.sourceforge.net http://pypi.python.org/pypi/roundup"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND=">=sys-libs/db-3.2.9"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+src_install() {
+ distutils_src_install
+ rm -rf "${ED}"/usr/share/doc/${PN} || die
+ dohtml -r doc/*
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.ini file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}
diff --git a/www-apps/roundup/roundup-1.4.21.ebuild b/www-apps/roundup/roundup-1.4.21.ebuild
new file mode 100644
index 000000000000..6701e54999a7
--- /dev/null
+++ b/www-apps/roundup/roundup-1.4.21.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="http://roundup.sourceforge.net http://pypi.python.org/pypi/roundup"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=sys-libs/db-3.2.9"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+python_install_all() {
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+ dohtml -r doc/*
+}
+
+pkg_postinst() {
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.ini file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}
diff --git a/www-apps/roundup/roundup-1.5.0.ebuild b/www-apps/roundup/roundup-1.5.0.ebuild
new file mode 100644
index 000000000000..bc00516e4d98
--- /dev/null
+++ b/www-apps/roundup/roundup-1.5.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces"
+HOMEPAGE="http://roundup.sourceforge.net http://pypi.python.org/pypi/roundup"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=sys-libs/db-3.2.9"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.txt doc/*.txt"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+ dohtml -r doc/*
+}
+
+pkg_postinst() {
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.ini file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}