summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-12 18:42:09 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-12 18:48:03 +0200
commit20f8702b523411504640360cbdec58983c338c4e (patch)
tree60754bfb4842d89606905a49983917239c417ecf /www-apps/selfoss
parentapp-containers/lxd: fix ebuild to support secure boot with VMs (diff)
downloadgentoo-20f8702b523411504640360cbdec58983c338c4e.tar.gz
gentoo-20f8702b523411504640360cbdec58983c338c4e.tar.bz2
gentoo-20f8702b523411504640360cbdec58983c338c4e.zip
www-apps/selfoss: bump to 2.19
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'www-apps/selfoss')
-rw-r--r--www-apps/selfoss/Manifest1
-rw-r--r--www-apps/selfoss/selfoss-2.19.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/selfoss/Manifest b/www-apps/selfoss/Manifest
index d0b0248d66bc..26dfba5b397d 100644
--- a/www-apps/selfoss/Manifest
+++ b/www-apps/selfoss/Manifest
@@ -1 +1,2 @@
DIST selfoss-2.18.zip 2881068 BLAKE2B aaf45ed5fa005cbfba0954a50412b37ec26e17de4308e9604a942861d63ade64149a048936871526f8b45a948555e6d5335152cc18c8664f9668d2e61350b4eb SHA512 6966458f4ef803ac87df7a2650aed73d6d99922f84d21f64950964b752535d3a1ddd8c585ce2ca5a3f58fb9f2de76fa7a0932ce2eb62faa753ed2398b6ebb748
+DIST selfoss-2.19.zip 5837647 BLAKE2B 0921d938a8c85c2d610fbbf371ab46c7b233d55e7db2531a7745f23920028878ac3f85c10d58bcd48da55e6efab367aa55889373260d8af36414747272f5a97e SHA512 d9b751e1d3725e4fc44353c579f6a8033c0802e0697627fd6e20adaf31a49f38ab485d6ea27bbcb645f48cc9de6db2bd451fe900f48f48e5e602171c2a71d634
diff --git a/www-apps/selfoss/selfoss-2.19.ebuild b/www-apps/selfoss/selfoss-2.19.ebuild
new file mode 100644
index 000000000000..a3a420945e26
--- /dev/null
+++ b/www-apps/selfoss/selfoss-2.19.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1 webapp
+
+DESCRIPTION="The multipurpose rss reader, live stream, mashup, aggregation web application"
+HOMEPAGE="https://selfoss.aditu.de/"
+SRC_URI="https://github.com/SSilence/${PN}/releases/download/${PV}/${P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="app-arch/unzip"
+RDEPEND="
+ >=dev-lang/php-5.6.0[curl,gd]
+ <dev-lang/php-8
+ virtual/httpd-php
+ || (
+ dev-db/mysql
+ dev-db/postgresql
+ dev-db/sqlite
+ )
+"
+
+DOC_CONTENTS="Default selfoss config is installed as defaults.ini,
+copy that config to config.ini and customize as you wish."
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/public
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_src_install
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}