summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/trac-accountmanager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/trac-accountmanager')
-rw-r--r--www-apps/trac-accountmanager/Manifest3
-rw-r--r--www-apps/trac-accountmanager/metadata.xml22
-rw-r--r--www-apps/trac-accountmanager/trac-accountmanager-0.3_p9766.ebuild30
-rw-r--r--www-apps/trac-accountmanager/trac-accountmanager-0.4.2-r1.ebuild23
-rw-r--r--www-apps/trac-accountmanager/trac-accountmanager-0.4.2.ebuild25
-rw-r--r--www-apps/trac-accountmanager/trac-accountmanager-0.4_p10645.ebuild30
6 files changed, 133 insertions, 0 deletions
diff --git a/www-apps/trac-accountmanager/Manifest b/www-apps/trac-accountmanager/Manifest
new file mode 100644
index 000000000000..0b887470c1ae
--- /dev/null
+++ b/www-apps/trac-accountmanager/Manifest
@@ -0,0 +1,3 @@
+DIST TracAccountManager-0.4.2.tar.gz 157706 SHA256 4f527394db9316e1f826b1bd0fb8d97253516daf35c6d5f71a016df317a57d74 SHA512 b73046dd15cefbe4d7854107af1bdf372ab5c2c6e83855395383b4a894d85325d867eaa1e9013f41ffcf8907baf3ea64873ac1b6c3b333af6dfd6480ab4016b4 WHIRLPOOL 5607957625a104596975fdf0283d9ae1c85a2f5c4a309aff0a04475e7f5123c8c53e45ba0f7d69a4bbe1e7c62912490356e5c48220d51ebbc9497b160f2bfac6
+DIST trac-accountmanager-0.3_p9766.zip 91200 SHA256 c1c6a23d464f53e148aa79272e6d76513d32379778d2c76afe42fc68a9c5568f
+DIST trac-accountmanager-0.4_p10645.zip 145212 SHA256 51d63b3c01ef951942a53669297aa7bb46285b4ef611a250a62f4f2d98d91f7b
diff --git a/www-apps/trac-accountmanager/metadata.xml b/www-apps/trac-accountmanager/metadata.xml
new file mode 100644
index 000000000000..96ad4fdf3737
--- /dev/null
+++ b/www-apps/trac-accountmanager/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <maintainer>
+ <email>djc@gentoo.org</email>
+ <name>Dirkjan Ochtman</name>
+ </maintainer>
+ <longdescription lang="en">
+ The AccountManagerPlugin offers several features for managing user accounts:
+
+ * allow users to register new accounts
+ * login via an HTML form instead of using HTTP authentication
+ * allow existing users to change their passwords or delete their accounts
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">TracAccountManager</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apps/trac-accountmanager/trac-accountmanager-0.3_p9766.ebuild b/www-apps/trac-accountmanager/trac-accountmanager-0.3_p9766.ebuild
new file mode 100644
index 000000000000..cb4f81c1e40e
--- /dev/null
+++ b/www-apps/trac-accountmanager/trac-accountmanager-0.3_p9766.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_DIR="accountmanagerplugin/trunk"
+MY_REV="${PV#*_p}"
+
+DESCRIPTION="A Trac plugin for manage user accounts"
+HOMEPAGE="http://trac-hacks.org/wiki/AccountManagerPlugin"
+SRC_URI="http://trac-hacks.org/changeset/${MY_REV}/${MY_DIR}?old_path=/&filename=${MY_DIR}&format=zip
+ -> ${P}.zip"
+
+LICENSE="BEER-WARE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ app-arch/unzip"
+RDEPEND=">=www-apps/trac-0.12"
+
+S="${WORKDIR}/${MY_DIR}"
diff --git a/www-apps/trac-accountmanager/trac-accountmanager-0.4.2-r1.ebuild b/www-apps/trac-accountmanager/trac-accountmanager-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..d0399156c592
--- /dev/null
+++ b/www-apps/trac-accountmanager/trac-accountmanager-0.4.2-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Trac plugin for manage user accounts"
+HOMEPAGE="http://trac-hacks.org/wiki/AccountManagerPlugin"
+SRC_URI="mirror://pypi/T/TracAccountManager/TracAccountManager-${PV}.tar.gz"
+
+LICENSE="BSD BEER-WARE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=www-apps/trac-0.12"
+
+S="${WORKDIR}/acct_mgr-${PV}"
diff --git a/www-apps/trac-accountmanager/trac-accountmanager-0.4.2.ebuild b/www-apps/trac-accountmanager/trac-accountmanager-0.4.2.ebuild
new file mode 100644
index 000000000000..d98b934f4aaf
--- /dev/null
+++ b/www-apps/trac-accountmanager/trac-accountmanager-0.4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A Trac plugin for manage user accounts"
+HOMEPAGE="http://trac-hacks.org/wiki/AccountManagerPlugin"
+SRC_URI="mirror://pypi/T/TracAccountManager/TracAccountManager-${PV}.tar.gz"
+
+LICENSE="BSD BEER-WARE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=">=www-apps/trac-0.12"
+
+S="${WORKDIR}/acct_mgr-${PV}"
diff --git a/www-apps/trac-accountmanager/trac-accountmanager-0.4_p10645.ebuild b/www-apps/trac-accountmanager/trac-accountmanager-0.4_p10645.ebuild
new file mode 100644
index 000000000000..cb4f81c1e40e
--- /dev/null
+++ b/www-apps/trac-accountmanager/trac-accountmanager-0.4_p10645.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_DIR="accountmanagerplugin/trunk"
+MY_REV="${PV#*_p}"
+
+DESCRIPTION="A Trac plugin for manage user accounts"
+HOMEPAGE="http://trac-hacks.org/wiki/AccountManagerPlugin"
+SRC_URI="http://trac-hacks.org/changeset/${MY_REV}/${MY_DIR}?old_path=/&filename=${MY_DIR}&format=zip
+ -> ${P}.zip"
+
+LICENSE="BEER-WARE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ app-arch/unzip"
+RDEPEND=">=www-apps/trac-0.12"
+
+S="${WORKDIR}/${MY_DIR}"