summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 19:31:51 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 21:24:32 +0100
commita6f52ea5c304d9fad8a68ee0edbc5a82882f85ed (patch)
tree49d4b529517c59fbc86c61ea3fb9648596144fb8 /www-apps/trac-tags/trac-tags-0.6-r1.ebuild
parentpython-r1.eclass: Wipe obsolete EAPI=4 exceptions (diff)
downloadgentoo-a6f52ea5c304d9fad8a68ee0edbc5a82882f85ed.tar.gz
gentoo-a6f52ea5c304d9fad8a68ee0edbc5a82882f85ed.tar.bz2
gentoo-a6f52ea5c304d9fad8a68ee0edbc5a82882f85ed.zip
www-apps/trac-tags: distutils-r1, EAPI=6
Diffstat (limited to 'www-apps/trac-tags/trac-tags-0.6-r1.ebuild')
-rw-r--r--www-apps/trac-tags/trac-tags-0.6-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-apps/trac-tags/trac-tags-0.6-r1.ebuild b/www-apps/trac-tags/trac-tags-0.6-r1.ebuild
new file mode 100644
index 000000000000..6f090a0e8606
--- /dev/null
+++ b/www-apps/trac-tags/trac-tags-0.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_REV="9901"
+MY_DIR="tagsplugin/tags/${PV}"
+
+DESCRIPTION="Tags plugin for Trac"
+HOMEPAGE="http://trac-hacks.org/wiki/TagsPlugin"
+SRC_URI="http://trac-hacks.org/changeset/${MY_REV}/${MY_DIR}?old_path=%2F&format=zip
+ -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/genshi-0.6[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip"
+RDEPEND="${CDEPEND}
+ >=www-apps/trac-0.11[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_DIR}"