summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-apps/webmcp/webmcp-1.2.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-apps/webmcp/webmcp-1.2.6.ebuild')
-rw-r--r--www-apps/webmcp/webmcp-1.2.6.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/www-apps/webmcp/webmcp-1.2.6.ebuild b/www-apps/webmcp/webmcp-1.2.6.ebuild
new file mode 100644
index 000000000000..115459de2eb2
--- /dev/null
+++ b/www-apps/webmcp/webmcp-1.2.6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-v${PV}
+DESCRIPTION="Web application framework written in Lua and C"
+HOMEPAGE="http://www.public-software-group.org/webmcp"
+SRC_URI="http://www.public-software-group.org/pub/projects/${PN}/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="HPND"
+KEYWORDS="~amd64"
+SLOT=0
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ dev-db/postgresql"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC)
+ # Dereference symlinks
+ cd framework
+ mkdir lib.link
+ mv lib/* lib.link
+ cp lib.link/* lib
+}
+
+src_install() {
+ into /usr/lib/${PN}
+ dolib.so framework/lib/*.so
+ for subdir in "" ".precompiled"; do
+ MY_DEST=/usr/lib/${PN}/framework${subdir}
+
+ cd framework${subdir}
+ exeinto ${MY_DEST}/accelerator
+ doexe accelerator/webmcp_accelerator.so
+ insinto ${MY_DEST}
+ doins -r env js
+ exeinto ${MY_DEST}/cgi-bin
+ doexe cgi-bin/webmcp*.lua
+ into ${MY_DEST}
+ dobin bin/*
+ insinto ${MY_DEST}/lib
+ doins lib/*.lua
+ cd ..
+
+ for file in extos.so mondelefant_native.so multirand.so; do
+ dosym ../../$(get_libdir)/$file ${MY_DEST}/lib/$file
+ done
+
+ insinto /usr/share/${PN}
+ doins -r demo-app${subdir}
+ done
+ dodoc doc/*sample.conf libraries/mondelefant/example.lua
+ dohtml doc/autodoc.html
+}