summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-05-01 05:19:00 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-05-01 05:19:00 +0200
commit6f24a81cb520d980ba42f0a637585caeb72312eb (patch)
treebccf943a782f3fcdca7acec40b075dff18ba2986 /www-apps/wordpress/wordpress-5.4.ebuild
parentapp-admin/salt-3000.2-r4: revbump, fix warnings with py38 (diff)
downloadgentoo-6f24a81cb520d980ba42f0a637585caeb72312eb.tar.gz
gentoo-6f24a81cb520d980ba42f0a637585caeb72312eb.tar.bz2
gentoo-6f24a81cb520d980ba42f0a637585caeb72312eb.zip
www-apps/wordpress: removed vulnerable 5.4
Bug: https://bugs.gentoo.org/720220 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'www-apps/wordpress/wordpress-5.4.ebuild')
-rw-r--r--www-apps/wordpress/wordpress-5.4.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/www-apps/wordpress/wordpress-5.4.ebuild b/www-apps/wordpress/wordpress-5.4.ebuild
deleted file mode 100644
index 6fc0786bf3b1..000000000000
--- a/www-apps/wordpress/wordpress-5.4.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit webapp
-
-DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
-HOMEPAGE="https://wordpress.org/"
-SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
-
-LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="virtual/httpd-php
- || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
-
-S=${WORKDIR}/${PN}
-
-need_httpd_cgi
-
-IUSE="+akismet examples +themes vhosts"
-
-src_install() {
- webapp_src_preinst
-
- dodoc readme.html
- rm readme.html license.txt || die
-
- if use !akismet ; then
- rm -R wp-content/plugins/akismet/ || die
- fi
- if use !examples ; then
- rm wp-content/plugins/hello.php || die
- fi
- if use !themes ; then
- rm -R wp-content/themes/*/ || die
- fi
-
- [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- webapp_serverowned "${MY_HTDOCSDIR}"/index.php
- webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
- webapp_serverowned "${MY_HTDOCSDIR}"
- # allows plugins update if allowed within WP
- webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/includes/file.php
-
- webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
- webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
-
- webapp_src_install
-}