summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-07-11 14:28:34 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-07-11 14:28:34 -0400
commitc8c48722e98cc0759583fbe0a18f27f88beeda44 (patch)
tree97a003ad471affb59ea75e7e32a5416bb78bdbda /www-apps/wordpress
parentnet-misc/curl: version bump to 7.61.0, bug #660894 (diff)
downloadgentoo-c8c48722e98cc0759583fbe0a18f27f88beeda44.tar.gz
gentoo-c8c48722e98cc0759583fbe0a18f27f88beeda44.tar.bz2
gentoo-c8c48722e98cc0759583fbe0a18f27f88beeda44.zip
www-apps/wordpress: version bump to 4.9.7
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'www-apps/wordpress')
-rw-r--r--www-apps/wordpress/Manifest1
-rw-r--r--www-apps/wordpress/wordpress-4.9.7.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/www-apps/wordpress/Manifest b/www-apps/wordpress/Manifest
index 880bbd1282ac..c000fbd71602 100644
--- a/www-apps/wordpress/Manifest
+++ b/www-apps/wordpress/Manifest
@@ -1 +1,2 @@
DIST wordpress-4.9.6.tar.gz 8740389 BLAKE2B 827f4cf4e1c664ee04588e189bb744b10ab0abbee0434d64c2ed65cb0ec289869b26f5ef6ae067a67f308e8f3a5b139c2d905897c0ed5be40eb2166ec3939a61 SHA512 93b5c6373968925f4773b79990ee73508c4994dc5ef4387c8d88dc7d39ae3688d4e066887870731e0b4e1d84a1c027cdc62239b3e042c133eb32a03229d48335
+DIST wordpress-4.9.7.tar.gz 8742203 BLAKE2B 3cb3a5379e96bffa11efcb4c51f948332179334f50ee49860618c7ec7cc485af8dd497c9566bc6dbd4a7a3c8c0f38cd333f2b90c57fef1604af946113cd96564 SHA512 0a9a132d48081ef253122bd207dbf859babfd021ef3db90d486c92cde03727a74c5170a9faf80d46e8899472a703cfe91b24c04c1ea21f261dbd156bd691ad12
diff --git a/www-apps/wordpress/wordpress-4.9.7.ebuild b/www-apps/wordpress/wordpress-4.9.7.ebuild
new file mode 100644
index 000000000000..19231ee76d17
--- /dev/null
+++ b/www-apps/wordpress/wordpress-4.9.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="Wordpress PHP and MySQL based content management system (CMS)"
+HOMEPAGE="https://wordpress.org/"
+SRC_URI="https://wordpress.org/${P/_rc/-RC}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[mysqli] )"
+
+S=${WORKDIR}/${PN}
+
+need_httpd_cgi
+
+IUSE="+akismet examples +themes vhosts"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc readme.html
+ rm readme.html license.txt || die
+
+ if ! use akismet ; then
+ rm -R wp-content/plugins/akismet/ || die
+ fi
+ if ! use examples ; then
+ rm wp-content/plugins/hello.php || die
+ fi
+ if ! use themes ; then
+ rm -R wp-content/themes/*/ || die
+ fi
+
+ [[ -f wp-config.php ]] || cp wp-config-sample.php wp-config.php
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/index.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/wp-admin/menu.php
+ webapp_serverowned "${MY_HTDOCSDIR}"
+
+ webapp_configfile "${MY_HTDOCSDIR}"/wp-config.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postupgrade_txt en "${FILESDIR}"/postupgrade-en.txt
+
+ webapp_src_install
+}