summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-09-01 21:46:38 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-09-01 21:52:05 +0100
commit72d1236def4d535921b89ab33546c492e4910987 (patch)
treea3a780c7620cee508d7195c2ac53e1c3b29e26cc /www-apps/xpra-html5
parentprofiles: Mask www-apps/xpra-html5[minify] on x32 (diff)
downloadgentoo-72d1236def4d535921b89ab33546c492e4910987.tar.gz
gentoo-72d1236def4d535921b89ab33546c492e4910987.tar.bz2
gentoo-72d1236def4d535921b89ab33546c492e4910987.zip
www-apps/xpra-html5: New package
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'www-apps/xpra-html5')
-rw-r--r--www-apps/xpra-html5/Manifest1
-rw-r--r--www-apps/xpra-html5/metadata.xml16
-rw-r--r--www-apps/xpra-html5/xpra-html5-4.3.ebuild43
3 files changed, 60 insertions, 0 deletions
diff --git a/www-apps/xpra-html5/Manifest b/www-apps/xpra-html5/Manifest
new file mode 100644
index 000000000000..98b742002433
--- /dev/null
+++ b/www-apps/xpra-html5/Manifest
@@ -0,0 +1 @@
+DIST xpra-html5-4.3.tar.gz 1520768 BLAKE2B f02cd4d751a9f929301199753d9ccc1c8da71378aedfece2ef248676525383b2fa6b0440fefee3c6c292449de9cafc38281d202237fcc1c96353b84bc0b2fbf6 SHA512 5bca4d8bf59b81c34dfc75b6b15475ff2a898015dac07d609d08efba0484d2eea5e31a50de45ffbf1e5c1701fe212dc4e964a177119990a2d39f486b8944b8f2
diff --git a/www-apps/xpra-html5/metadata.xml b/www-apps/xpra-html5/metadata.xml
new file mode 100644
index 000000000000..7ea60186d2df
--- /dev/null
+++ b/www-apps/xpra-html5/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Xpra-org/xpra-html5</remote-id>
+ </upstream>
+ <use>
+ <flag name="brotli">Install assets compressed with brotli</flag>
+ <flag name="gzip">Install assets compressed with gzip</flag>
+ <flag name="minify">Minify JavaScript code for smaller transfers</flag>
+ </use>
+</pkgmetadata>
diff --git a/www-apps/xpra-html5/xpra-html5-4.3.ebuild b/www-apps/xpra-html5/xpra-html5-4.3.ebuild
new file mode 100644
index 000000000000..636eaaff0e17
--- /dev/null
+++ b/www-apps/xpra-html5/xpra-html5-4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit python-any-r1
+
+DESCRIPTION="HTML5 client to connect to any xpra server"
+HOMEPAGE="https://xpra.org/"
+SRC_URI="https://github.com/Xpra-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="brotli +gzip minify"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ brotli? ( app-arch/brotli )
+ minify? ( dev-util/uglifyjs )
+"
+
+src_configure() {
+ cat <<EOF > vcs-info || die
+BRANCH=gentoo
+REVISION=${PR#r}
+LOCATION_MODIFICATIONS=0
+EOF
+}
+
+src_install() {
+ "${PYTHON}" <<EOF || die
+import setup
+setup.set_version("${PV}")
+setup.install_html5(
+ "${ED}/usr/share/xpra/www",
+ "$(usex minify uglifyjs copy)",
+ brotli=$(usex brotli True False),
+ gzip=$(usex gzip True False)
+)
+EOF
+}