summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-04-14 09:56:56 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-04-14 09:58:17 +0300
commit053afd30090cd96adb319edaf4e00889d4a98460 (patch)
tree6f4ab4358282f76e1f1234812014ea4ad6edd75e /www-apps
parentmedia-gfx/img2pdf: Stabilize 0.4.4-r1 x86, #904289 (diff)
downloadgentoo-053afd30090cd96adb319edaf4e00889d4a98460.tar.gz
gentoo-053afd30090cd96adb319edaf4e00889d4a98460.tar.bz2
gentoo-053afd30090cd96adb319edaf4e00889d4a98460.zip
www-apps/dokuwiki: add 20230404
Closes: https://bugs.gentoo.org/876244 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/dokuwiki/Manifest1
-rw-r--r--www-apps/dokuwiki/dokuwiki-20230404.ebuild86
-rw-r--r--www-apps/dokuwiki/metadata.xml3
3 files changed, 90 insertions, 0 deletions
diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
index fd175879da7f..f64f85e696c1 100644
--- a/www-apps/dokuwiki/Manifest
+++ b/www-apps/dokuwiki/Manifest
@@ -1 +1,2 @@
DIST dokuwiki-2020-07-29.tgz 3821413 BLAKE2B bd14ec2450365befb85afdefc6bb078f10bdf1659d85adac3bbb2f502d29f3e706fb277d65810103e66b0c692f7166ed3c8d9e780489c08fb7ef9695de550d75 SHA512 093474bf5d5bb2c95400692927cbc8ffbe7666f178ffaa648a043ef05a2b32471feeed5de282c36b41e6e80e0a065909ea2ced8ecffc7fb339bda902697d596c
+DIST dokuwiki-2023-04-04.tgz 4032792 BLAKE2B 32bc42d6fd5d869bfc08ee8fc7214f42dfdb4812eea74d04d2566dc3c75f5a7069b62bbc0b8eaca389322d971ffc35c6d40e8257658e38f9cebf96ab2bd47bd6 SHA512 1539f9306916ce1f759a07168a02dab05ee044b3637ce96cf94d67b84027f5774cb2a9f493c8067ff70176d7b018c54cded1251e35022c8f9dfed74fd4fa501f
diff --git a/www-apps/dokuwiki/dokuwiki-20230404.ebuild b/www-apps/dokuwiki/dokuwiki-20230404.ebuild
new file mode 100644
index 000000000000..c6d2a56a3fa0
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20230404.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+
+if [[ ${PV} == *rc* ]]; then
+ MY_PV="${MY_BASE_PV}${PV:8:4}"
+ MY_P="${PN}-rc-${MY_BASE_PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-rc.tgz -> ${PN}-${PV}.tgz"
+else
+ MY_PV="${MY_BASE_PV}${PV:8:4}"
+ SRC_URI="https://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs"
+HOMEPAGE="https://wiki.dokuwiki.org"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~sparc ~x86"
+IUSE="gd"
+
+DEPEND=""
+RDEPEND="
+ >=dev-lang/php-7.4[xml]
+ virtual/httpd-php:*
+ gd? ( ||
+ (
+ dev-lang/php[gd]
+ media-gfx/imagemagick
+ )
+ )
+"
+
+need_httpd_cgi
+
+src_prepare() {
+ # create initial changes file
+ touch data/changes.log
+
+ default
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README
+ rm -f README COPYING
+
+ docinto scripts
+ dodoc bin/*
+ rm -rf bin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Copy custom .htaccess that works with both apache 2.2 and 2.4
+ for dir in "conf" "data" "inc" "inc/lang"; do
+ insinto "${MY_HTDOCSDIR}/${dir}"
+ newins "${FILESDIR}/htaccess" ".htaccess"
+ done
+
+ # Use custom .htaccess.dist that works with both apache 2.2 and 2.4
+ insinto "${MY_HTDOCSDIR}/"
+ newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
+
+ for x in $(find data/ -not -name '.htaccess'); do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+ webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+ for x in $(find conf/ -not -name 'msg'); do
+ webapp_configfile "${MY_HTDOCSDIR}"/${x}
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}
diff --git a/www-apps/dokuwiki/metadata.xml b/www-apps/dokuwiki/metadata.xml
index 0ebf9ea835d1..9e5234c9d3ab 100644
--- a/www-apps/dokuwiki/metadata.xml
+++ b/www-apps/dokuwiki/metadata.xml
@@ -14,4 +14,7 @@
eases the creation of structured texts. All data is stored in plain text
files - no database is required.
</longdescription>
+ <upstream>
+ <remote-id type="github">dokuwiki/dokuwiki</remote-id>
+ </upstream>
</pkgmetadata>