summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-03-24 12:19:52 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-03-24 12:19:52 -0100
commit05b29c8bdb0d5ac4a3160c2840c72f36ad0781c2 (patch)
tree19faa9ad95b4939a22ed1bf158e32d30734638f7 /www-apps
parentnet-libs/http-parser: Version 2.9.4 (diff)
downloadgentoo-05b29c8bdb0d5ac4a3160c2840c72f36ad0781c2.tar.gz
gentoo-05b29c8bdb0d5ac4a3160c2840c72f36ad0781c2.tar.bz2
gentoo-05b29c8bdb0d5ac4a3160c2840c72f36ad0781c2.zip
www-apps/drupal: Security bump - SA-CORE-2020-001.
Add 8.7.12 and 8.8.4 releases. Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest2
-rw-r--r--www-apps/drupal/drupal-8.7.12.ebuild68
-rw-r--r--www-apps/drupal/drupal-8.8.4.ebuild68
3 files changed, 138 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index f57bf074562a..23f955b57c91 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,5 +1,7 @@
DIST drupal-7.69.tar.gz 3314294 BLAKE2B bfa1d528caf5dc1fa8a21d65244801e2d10961ec707bdb05c99cdd4fbb1e8f90692549b00befd29583371791a22fdf46af87dcc8c43204dce6ba505376bff5d4 SHA512 521eec475cbd11d9c997f660c8cd3f92e7a164650eaec67bc1d40c53e901576bc827a3805d2341ab80e9a5bb2f4524e7541d0a99970f2a51a3e45a9ac8ae7880
DIST drupal-8.7.11.tar.gz 17899106 BLAKE2B b0971595319abcae978a0a85f3d11345e3411d412775754139c9562baf5e3c4e49f5ff279139ab1b2128f72987746f13b3edb801cca9984269ce929492243f79 SHA512 1952630cce84c3d819e9f34e2beed3268f0e6aaa634aa367310b4aad59c1d86a59fe11d258aa6d0823cd0d2c227ce54d88fc27e07c53b660a6833e1f15feb9f1
+DIST drupal-8.7.12.tar.gz 17917274 BLAKE2B 931876fffaab011416d992910317e0b24f89ea4c01fbb09e7d256fb90652b30509051d60c61863434762eccf382ed9f25be41f84b797ffba89aff83a15ff908d SHA512 f9b140d52d11d9ec0543b8e18315b898f1d09bb4c360c544498b1b6df8d40e59c04e5e04749140c896c51f2ea1844fab8220dd556986b39af0fc846d2571e5c2
DIST drupal-8.8.1.tar.gz 19409293 BLAKE2B f0fb8874fc4c706f15ab35795357088d4edf75a2bac23343feadf9e02a706f553d3985c418369c76ede310744c645d3ca4085d920f1bd3069c36d31ef3b90d52 SHA512 68663b078c7e4468d8fcaa82c385c79930d4d5741e9ec598faeda6b1f8eeb37dbd8a841bc5a458c1dc97dda9a566edaa981991cdd19fea1edc963f72d746c639
DIST drupal-8.8.2.tar.gz 19438764 BLAKE2B d37d1a4387b8873d6b42ed6afcae89025325aefddecfc3528b161fc86898630f6117301217b4aeeff0aa35ee906aa21de367dc1958db27ec26987c1e599217db SHA512 e4ec3e93649e1698da95a46af9087068beaf5c89a7941d7a3d9fd90d5d28a6ba765cc2ba1954a9c27117197e4322df711c07017b29fd89abc75bfa596fa58362
DIST drupal-8.8.3.tar.gz 19473677 BLAKE2B a9d9788e90b5cf137276246f503dc0ce9a01baec55a8666d51ff987ed3742a74f53fb684bd1fea70eadb6fcb113387f520aed14c2666f244ae3681cbd446d346 SHA512 d0a4cfec09699da1f206f425c598b9beaae5e34c8a3bab27b7639bc5d27515126ba4ff3af78357964a9998e1d8fce7baf935821db149ec091bc6af45906054f1
+DIST drupal-8.8.4.tar.gz 19488274 BLAKE2B 47cd41ec3d494f5dc948d70c45072fa8040698db133141947348b201e9853c04b91460b1c064d36e45dd20d0ce99c2a1a592e4f2a0f99348cdfd08fb97b9f0e1 SHA512 e85e1262eff6274ada1d2625fbd7744b22611807e55252fcaeae722dae5dbc1c552841681f80d552e2d68f7ab2cdca8915e9a2e4c3dac9870fa92c0cb3910286
diff --git a/www-apps/drupal/drupal-8.7.12.ebuild b/www-apps/drupal/drupal-8.7.12.ebuild
new file mode 100644
index 000000000000..50acdd30770d
--- /dev/null
+++ b/www-apps/drupal/drupal-8.7.12.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}
diff --git a/www-apps/drupal/drupal-8.8.4.ebuild b/www-apps/drupal/drupal-8.8.4.ebuild
new file mode 100644
index 000000000000..50acdd30770d
--- /dev/null
+++ b/www-apps/drupal/drupal-8.8.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}