summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-05-09 02:32:43 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2019-05-09 02:32:43 +0000
commit083d121a9116b38623c16fc68071003bb180379c (patch)
tree5924f6cdca0a4726dcfdba51630e1116b7e5f39b /www-apps
parentnet-wireless/chirp: bump (diff)
downloadgentoo-083d121a9116b38623c16fc68071003bb180379c.tar.gz
gentoo-083d121a9116b38623c16fc68071003bb180379c.tar.bz2
gentoo-083d121a9116b38623c16fc68071003bb180379c.zip
www-apps/drupal: Security bump - SA-CORE-2019-007.
Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest3
-rw-r--r--www-apps/drupal/drupal-7.67.ebuild74
-rw-r--r--www-apps/drupal/drupal-8.6.16.ebuild84
-rw-r--r--www-apps/drupal/drupal-8.7.1.ebuild84
4 files changed, 245 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index f8f1020feba0..bdd13c706582 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,6 @@
DIST drupal-7.66.tar.gz 3300183 BLAKE2B 89d82c7018ecade0f798df92087d704ca9f5847780a1c3106e69afda62b43c414d57f01584e2869e72fc3687370b0bad84c2a7ffc0ca90537be55cb36ce6edac SHA512 c348eeeabfb5fef05b28aa87c9885231bd5e676b1ced64a2f51cc2aefa122b5ce142aae2ede5c1479608c893195450ae25168bae971b8e77cc741b18650f75c8
+DIST drupal-7.67.tar.gz 3312764 BLAKE2B bb7f21e80ca192ff3e37f917c1fa43dcd8d3cd8b60ff012d1fe22e279ffd674e08be6aef6328d0c5b7c50a106592bde299300fe9ccb0c4c1ffc1aca57c3ca6ad SHA512 0e4f60010b1395183cea19424e8c2849f93fb7285a081bf7d0c774b8e82f403083533059f58c3831950cc06dfa8117d443db52b66a521301ceac10b1b333aa28
DIST drupal-8.5.15.tar.gz 15828193 BLAKE2B 3a90ad525da3d81f555461e28decea7977cb51eda5f2e3be89dcd38f05b94cc6743967e19d21d89572babc05c38ab4d3585e4b7ffb52677b50b19844400fbcdf SHA512 aa09a28d7dcba51e193bba2a714eef091773d5e12a3a7388db8925c791a7153a4333db6150a8a68fe21b04009887dcf60f16f237a86d52bd2cc7d28ada301221
DIST drupal-8.6.15.tar.gz 17137689 BLAKE2B 098847cc4a3a52a6c5d9af23c31e5dca43c2f9cbb4ac0f7d2724cf6b6ce98598b75750742c695e666000843f6fa855e2ba414ceb0d9b46f9baff244cc583ef64 SHA512 9a8d9c73f7812b6deca4bcfee0e04d485bfac5efa6e9112379fdacc727ecf0e40703ce9b141c7414357c296eb621a015aa1c97ab8e6bbe4d35c38b2f1c323337
+DIST drupal-8.6.16.tar.gz 17151378 BLAKE2B 2bdd14ff7a5f898af2d322a6b2862643899dfbe2ad05c99b85f036161612cccfc2c25105c8eef37311634a2aa03ed792db8de3e625aed5adb94cd8f644557fcb SHA512 34f260d780bce286a0a61b710c340d2622cb857aa92a2bdaad63737303ef2f4f1751edc3f415daaa14b9cb483757e367e639136d03f571cba5165129bba31e12
+DIST drupal-8.7.1.tar.gz 17811529 BLAKE2B 5bdb92a8f6c5675dd311417db526be81149240a053bdb94f4294cb571193ed03f2edbc83b51cbcce9e0e322b45981d0949714659f5db2dff211815232cd447e5 SHA512 a386f7991465eade203aba4b20bb894041c76abda97e93afd772a02b215ac496d57a9aed50820a7bd78604c9e6602180fcda933c5121b8536a7d610a3bc3f2e8
diff --git a/www-apps/drupal/drupal-7.67.ebuild b/www-apps/drupal/drupal-7.67.ebuild
new file mode 100644
index 000000000000..2d1f90ebbd06
--- /dev/null
+++ b/www-apps/drupal/drupal-7.67.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}
diff --git a/www-apps/drupal/drupal-8.6.16.ebuild b/www-apps/drupal/drupal-8.6.16.ebuild
new file mode 100644
index 000000000000..a8514d07dfe0
--- /dev/null
+++ b/www-apps/drupal/drupal-8.6.16.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}
diff --git a/www-apps/drupal/drupal-8.7.1.ebuild b/www-apps/drupal/drupal-8.7.1.ebuild
new file mode 100644
index 000000000000..a8514d07dfe0
--- /dev/null
+++ b/www-apps/drupal/drupal-8.7.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}